How to set up autostart of the Flatpak application?

Good morning!

I need to autostart the Flameshot and I tried different ways:

  • ln -s /var/lib/flatpak/exports/share/applications/org.flameshot.Flameshot.desktop /home/aes4096/.config/autostart
  • Added an application to autorun through GNOME Tweaks.
  • Added an application to autorun through Startup Application.
  • Combined different ways.

I note that in Fedora Linux one of the above methods works fine. Perhaps this is due to the fact that it uses vanile GNOME. The application via ppa and snapstore also does not work in autorun using Startup Application and GNOME Tweaks. However, the snap version of the application worked fine in the Startup Application using the flameshot %F command. But this was before the previous installation of the operating system and it works every other time.

Please help me to solve the problem.

Version my OS - ZorinOS 16.2 Pro

Hello,

Try making a command script instead eg.

sh -c "command to launch"

I'm battleing on a different field with flameshot. A good hint from @Aravisian pointed me to the following page:

later on this page, there are some suggestions to come over the autostart problems (with some delay - I don't understand) but it may be helpful for you to find a solution.

Adding some delay allows the application to only initialize after other drivers that the application will need has initialized.

1 Like

okay thank you, now I understand that

Add this command to your startup applications:

flatpak run org.flameshot.Flameshot

1 Like