How to skip grub menu

I'v seeing grub menu every time i boot into the system
Here is my grub settings:

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)

# Uncomment to disable graphical terminal (grub-pc only)

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux

# Uncomment to disable generation of recovery mode menu entries

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"


There is no any other OS alongside the zorin
Any help will be appreciated

1 Like

Does it show up for 30 seconds? If so, that's a 'recordfail' problem. Search for that, you'll see there's a lot of causes. I struggled valiantly to get around that problem, ended up just reinstalling the OS.


This should be set to a non-zero number. try 3 or 5... If in future you must access the Recovery Menu, setting this to zero can seriously inhibit your ability to do so.

What is the terminal output of



Here's the output:

BootCurrent: 0005
Timeout: 2 seconds
BootOrder: 0005,2001,0003,2002,2004,2005,2006,0002,0000,0001
Boot0000  Boot Device List
Boot0001  Diagnostic Menu
Boot0002  UiApp
Boot0003* HDD/SSD
Boot0005* ubuntu
Boot2001* USB Memory
Boot2002* USB ODD
Boot2004* LAN1
Boot2005* LAN2
Boot2006* FDD
Boot3001  HDD Recovery

There is a progress bar at the top of the screen and if I dont press the enter it will automatically boot into the zorin
I think the progress bar is a 30 second timer
Is there any problem with that?

Did you perform the sudo update-grub command after making your changes to the grub.cfg?

1 Like

Yes I did

But here we see:

Your default is 0 but the first bootable position for Zorin OS is in position five.
You can try setting:

While you are in there, you might add this line:


Please be sure to run sudo update-grub before rebooting to test.


Thanks it worked

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.