[How to] solve HP printer/scanner issues [HP Photosmart 6520]

I've read a lot of difficulty here on this topic. With all the help I've gotten here, I thought it would be in order that I share something I eventually solved. I'll skip the gory details of the saga, other than I've read that techies are often frustrated by the lack of HP support.

My HP Photosmart printer/scanner was working upon Z16 installation, but at some point it became defunct and I went through all the hoops I read here about.

WHAT FINALLY SOLVED IT FOR ME: 1) On the physical printer intself's panel, I hit "Restore to Factory Default" (I don't really know that to be relevant). 2) unplug printer/scanner & make sure it's removed from settings GUI. 3) From How to Enable & Disable AppArmor on Ubuntu 20.04 - LinuxCapable sudo systemctl stop apparmor . 4) Replug printer/scanner & ADD printer in GUI. 5) Then I was able to use the defunct scanner function again that I thought became "bricked". 6) sudo systemctl start apparmor .

Evidently the native AppArmor was causing an obstruction.

For whatever that was worth, I hope it helps.

2 Likes

Thanks for making this great tutorial :slight_smile:
If it is OK, I'd like to move it to the Tutorial section where more people will benefit from it.
Also could you give me the model number of your HP printer? I'd like to add that information in the title.

HP Photosmart 6520

1 Like

Thanks for this additional info :slight_smile:
I moved it to the Tutorial section with my moderator's magic wand :star2:

1 Like

EDIT:

THE LONG ANSWER:

I needed to get this HP Photosmart 6250 fix permanent across reboots.

This is because in the above fix, we need apparmor restarted to do its job, but it's then a matter of time before things get fouled up again. I double-checked the following over a couple reboots and it has this HP Photosmart 6250 printer/scanner acting right as intended.

Ubuntu 20.04 installs ippusbxd and runs it when a printer is plugged into a USB port. In short, ippusbxd is some network protocol which will mix a USB printer-scanner up.

Audit of var/log/syslog shows this ippusbxd to be getting blocked by apparmor. I followed instructions toward the bottom of that same link, How to Enable & Disable AppArmor on Ubuntu 20.04 - LinuxCapable to come up with the following fix, which effectively disables only the relevant restrictive apparmor profile, ippusbxd, rather than TEMPORARILY stopping the ENTIRE apparmor program.

THE TO-THE-POINT TUTORIAL:

  1. unplug printer/scanner & make sure it's removed from settings GUI.

  2. run the following in a terminal:

sudo ln -s /etc/apparmor.d/usr.sbin.ippusbxd /etc/apparmor.d/disable/
sudo apparmor_parser -R /etc/apparmor.d/disable/usr.sbin.ippusbxd

    (If done properly, you should see usr.sbin.ippusbxd in the 
     /etc/apparmor.d/disable folder).
  1. reboot

  2. plug in printer/scanner

  3. test printer or run the command “simple-scan” to test the scanner.

1 Like