How to turn bluetooth off at startup?

I don't always use bluetooth devices with my laptop, so I would like to save some battery and only turn in on when I need to.

I followed this tutorial to disable the bluetooth service at startup. Unfortunately, this means I would have to type the command in the terminal, log out and back in again for it to activate. I can't simply turn on bluetooth via task bar or settings anymore.

Does anyone know if it is possible to change the status of the bluetooth connection to OFF instead of ON at system start?

Have you looked at this page? There seems to be more than one way to accomplish what you wanted to do.

4 Likes

Thanks! This was much easier than expected. Since there are a few solutions in the linked article, I would just like to point out, that it was sufficient for me to edit
/etc/bluetooth/main.conf

I simply changed the last line from AutoEnable=true to AutoEnable=false and that did the job :+1:

3 Likes

Little update here. I don't know if it only worked once after a restart and then didn't anymore. The solution mentioned isn't working anymore though:

But there is a good alternative if you have the same problem like me (bluetooth still keeps being enabled even with the new line in the main.conf).

Install TLPUI and go to Configuration -> Radio -> Devices to disable on startup -> bluetooth. That should do the job!

4 Likes

I had the same issue and was waiting for someone to post a solution.Thanks for the answer !!

2 Likes

Thanks for this follow up.
I selected your posting as a solution :ballot_box_with_check:

1 Like

That's even better! So it was worth updating the issue on the forum :slight_smile:

I have also noticed a significant slowdown of the WiFi when activating bluetooth. This doesn't happen on M$ Windows on the same machine... So, I don't know how to solve that problem yet and if it even is possible to fix software-wise.

1 Like

Indeed.
As we learn Linux more, coming up with a better idea is a natural course :slight_smile:

I experienced the same thing with my Intel Compute Stick. Bluetooth signal interferes with WiFi in Linux. This does not happen in Windows. I think it is a matter of the quality of the driver (which works like an interpreter between software and hardware).

My work-around was disable Bluetooth in BIOS and use external USB Bluetooth dongle. I suppose you could do the other way around as well, that is, disable WiFi in BIOS and use USB WiFi dongle.

2 Likes

Thanks, @FrenchPress

I feared something like that would be the case. So there is no way a driver update might fix it in the future, you think? That's unconvenient but I guess something I will have to live with...

1 Like

My Intel Compute Stick (which is in reality, a poor (wo)man's Intel NUC) never got this problem solved until today. Solution might come one day but we never can predict.

I do not expect Windows PC to be 100% compatible with Linux.
If one needs such hardware, it is imperative to purchase those Linux pre-installed machines.

Since I have no unrealistic expectation, I do not get frustrated even if things do not work. There is always a work-around to be discovered.

The analogy is the daily cooking in the kitchen.
As I can not find all ingredients I need to make Japanese dishes, I have to replace some ingredients with French ones.
For example, I discovered Muscat wine nicely replace Japanese sake for cooking.

It is a challenge to be enjoyed and should not be a torture.

2 Likes