How to undervolt cpu & gpu in zorin os 16

I have a gf 65 thin 10 ser MSI laptop, it runs too hot out of the box but I successfully managed to disable the turbo and modify other cpu settings in throttle stop in windows 10, also with msi afterburner I was able to successfully undervolt the gpu so I would get lower temps.

Currently my cpu in zorinos 16 is reaching temps as high as 98c while just browsing on mozilla firefox (psensor reports this), I imagine when gaming my gpu will be reaching the high 80c's as well.

How can I implement a cpu undervolt in zorins 16 + a gpu undervolt to lower these super high temps, I can possibly disable turbo for the cpu in the bios and that would probably work but If there is a software way to disable turbo and modify cpu voltage and frequencys in zorin os 16 that would be great.

thank you for your time, God bless.

What’s the output of inxi -t cm while it’s running hot? Try to do this when it’s hot but with minimal applications running.

1 Like

I dont know how to get to that output I am new to linux, but here is a screenshot of my psensor cpu temps, cpu is just running way to hot, in my undervolt setup in win10 it does not reach max temps in the 90s.

Use the terminal, Ctrl+Alt+t pops up the terminal. Then in the terminal enter inxi -t cm. If it tells you inxi is not installed then it will give you the command to install it.

1 Like

yeah it says it can be installed what is it for?

For many purposes. The purpose for this thread is to determine what the biggest resource hogs are. It’s much easier, in my opinion, than using the resource monitor pic that you posted.

2 Likes

seems like not much is using up resources, its just a matter of these laptop cpus having too much of a power draw thus causing the heavy spikes in cpu temps while merely browsing in firefox. Looks like theres an app for undervolting its called "intel-undervolt" Undervolt your CPU with intel-undervolt! - YouTube

That’s very strange but not the first case of low usage & high temp combination. At least a couple of such instances on the forum.

https://forum.zorin.com/search?context=topic&context_id=14013&q=CPU%20in:title&skip_context=true

Yeah, you could use that application you found. I can’t opine on it. If it were me, for the GPU I’d switch to another driver (Software Updater -> Settings -> Additional Drivers) and see. I’ve had my GPU run hot because of wrong driver.
But that’s just my 2 cents.

1 Like

I have an nvidia rtx 2060 what gpu do you have, how do I check what gpu drivers are currently installed?

This happened on my desktop. Nvidia 750Ti had fan running constantly. I switched drivers and the it ran only under high load.

Software Updater -> Settings -> Additional Drivers -> switch to any other one and try. The one that’s selected is the one currently installed.

2 Likes

I have found a command in terminal that disables the intel cpu turbo it is this command.

echo 1 | sudo tee /sys/devices/system/cpu/intel_pstate/no_turbo

Disabling of the intel cpu turbo will significantly reduce cpu temps and it is ideal to my using of this laptop.

I can confirm it does disable turbo by firstly observing the cpu clock frequencys in real time with this command

watch "grep 'cpu MHz' /proc/cpuinfo"

I observe the frequency rise above the normal cpu frequency, then when I run the above command that disables the intel cpu turbo, I see that it does not go past the normal frequency anymore.

But how can I automate the disabling of the turbo command so it disables the intel cpu turbo everytime i log on in zorin os.

This may help: cpufreq - GNOME Shell Extensions

Nice, Ill try it out thank you.

1 Like

how do I install it from the terminal

You can search Youtube on how to apply a CPU undervolt, in the BIOS, for MSI notebooks. I can tell you right now, it will require the special key combination to unlock the full BIOS.

I have a MSI GE76-231 Raider notebook, and I have a -50mv undervolt applied to mine for that exact reason. You can go as high as a -80mv undervolt safely, but please note that some apps may still glitch out. This is the reason why I am only going as high as a -50mv undervolt.

If you look inside my notebook, you will find this...

It gives you the feeling that you have adequate cooling, but in all actuality, it is not optimal at all, if the CPU & GPU are pushed to their limits. The -50mv undervolt does help in dropping temps a bit, but what really helps, is my AFMAT cooling pad!

My Psensor temps while idle...

And, if I push my computer hard while gaming, usually the hottest my temps get is around 85C, but that is momentary, meaning, not at 85C all the time, just momentary reaches there, or a quicker spike to maybe 88C, but doesn't hold there. Usually while gaming, my temps will average around 65C.

Anyways, I won't give you the specific instructions to apply the undervolt, as you can do great damage to your computer in the BIOS, as in bricking it, I won't be responsible for that. So instead, I'll tell you to look up how to do it on Youtube. Good luck!


2 Likes

When I tried that I used #1 here: How to Install Gnome Shell Extensions
And then I went to that webpage and installed cpufreq.

thank you for your input, Yes i have learned how to apply an undervolt to the intel cpu on zorin 16 os now, But i decided to just disable the turbo only for now and monitor the temps, would you know how to undervolt the gpu in zorin 16

There is no way of undervolting the Nvidia GPU that I am aware of. However, you can apply in the BIOS, forced power management settings, that will prevent the GPU from turboing to its multiple stage power levels. Again, be careful when applying such settings, as you could brick your device.

Usually, by default, Nvidia operates by automatic adaptive boost, when required. If you load up Nvidia X Server Settings, you can usually find the turbo boost options there, but again, there is no way to disable turbo there, you can only select a couple of turbo based options.


1 Like

ok thank you I will not mess with the bios gpu settings, will look for an alternate in zorin OS gpu undervolt method