[HowTo] Civilization VI (Steam)

Greetings,

Even though Civilization 6 runs natively in Linux - there's an error that deny you to run the game.

  1. Download the game via Steam
  2. Go to the location you installed it and go to /steamapps/common/Sid Meier's Civilization VI
  3. Find the text file called Civ6 and open it with a text editor app.
  4. Change ./GameGuide/Civ6 to ./Civ6Sub
  5. Save the text file.
  6. ???
  7. Profit!!!

Enjoy!

2 Likes

Okay, something's wrong here. When I go to /steamapps/common/Sid Meier's Civilization VI there is no text file called Civ6. I tried eyeballing it. I tried doing a search. It's not in that folder. Either the name of the file has changed with a patch or something, that's not the name of the file, or you've misstepped.

Yes, it's there in yours all right. This is what I see in mine:

Verify: is that the correct path?

Looks like i. By any chance you're running it through Proton?
Again something doesn't look quite right/different like different folders then mine.

My point exactly, its different. Yes, I'm running it through Proton experimental, but in trying to remedy this issue I've switch Steam to Linux compatibility and back. I didn't check this folder.

Not only is there no Civ6.txt in that folder, but I couldn't locate it anywhere on my hard drive. Maybe that's the actual problem? It's looking for one that isn't there?

I did manage to start Civ once, but it crashed after I reached the "Create a Game" options and before the start of play.

Let's take it from the start. Uninstall all the steam app you downloaded and use the one in the repositories.

sudo apt install steam

Then when downloading Civ6 don't activate Proton as it run natively in Linux.

You might also want to remove ~/.steam when I think of it.

I have to work. I'll continue this after 5 cdt.

1 Like

Thank you for your help so far.

I removed Steam via the App Store.

However, it's stayed on my applications menu, has its icon on my desktop, and still has an icon on my app menu. Oh, and all its folders are intact.

When I try to remove by the command line: sudo apt remove steam, it tells me "Package 'steam:i386' is not installed, so not removed."

I can open Steam, see my library. I turned off Proton. Waited for it to reconfigure, went to the /steamapps/common/Sid Meier's Civilization VI, and it looks something like yours with several more files including the Civ6.txt file. I made the change you recommended.

And Civ starts, not full screen, but in a minimized window. And it gets through its intro into the start menu. But when I click on "Create a Game" the foreground menu disappears, and leaving the background sun gif running back and forth.

It may be a resolution problem.
Try manual edit the AppOptions.txt and GraphicsOptions.txt or try delete them so it create some new one.
You find them in ~/.local/share/aspyr-media/Sid Meier'''s Civilization VI'

I appreciate all your time, Storm.

The problems aren't remedied yet. I started Civ VI through Steam on Mint, and it has the same startup issues. This tells me they're issues between Ubuntu and Civ, so others must've seen this. I just can't seem to find them.

The fixes you recommended don't have any effect.

The issues change depending on if I'm using Proton or Forced Linux compatibility.

  1. On forced Linux, I get the start movie and then the directory. But it's in a window and not full screen, and it crashes when I choose "create a game" from the menu.

  2. Using proton experimental and forcing it on Civ, it usually only gives me the Loader screen and then crashes. Once I got as far as the Create a Game menu, I chose some options, then the "Start" button doesn't respond.

I've only observed this problem the Menu crash when I've chosen Create a Game or Worldbuilder. The menu disappears and the background "sun gif" continues.

It works if I just start a game with a random leader on Prince level, but I'm not interested in that.

It doesn't matter if I deactivate all mods except Rise & Fall and Gathering Storm. I'm not interested in the vanilla game.

I solved this problem before. I had this issue for months after installing Zorin. It was a real letdown for the new OS. Checking my log, I solved the problem in April. Unfortunately, I didn't write down exactly how I did it. I thought I remembered, but apparently, I missed the crucial part.

But the important thing is, I know Civ 6 can work with Zorin. I'm going to be looking through my Zorin notes.

1 Like