HP 15 Notebook cannot detect my bluetooth adapter

I recently switched to linux from windows. After trying different distros, finally settled for Zorin OS core. But, the OS is not detecting my bluetooth adapter. Did some googling and tried different kind of methods. None worked so far. Here's my lspci result:

00:00.0 Host bridge: Intel Corporation Haswell-ULT DRAM Controller (rev 09)
00:02.0 VGA compatible controller: Intel Corporation Haswell-ULT Integrated Graphics Controller (rev 09)
00:03.0 Audio device: Intel Corporation Haswell-ULT HD Audio Controller (rev 09)
00:14.0 USB controller: Intel Corporation 8 Series USB xHCI HC (rev 04)
00:16.0 Communication controller: Intel Corporation 8 Series HECI #0 (rev 04)
00:1b.0 Audio device: Intel Corporation 8 Series HD Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 8 Series PCI Express Root Port 1 (rev e4)
00:1c.1 PCI bridge: Intel Corporation 8 Series PCI Express Root Port 2 (rev e4)
00:1c.2 PCI bridge: Intel Corporation 8 Series PCI Express Root Port 3 (rev e4)
00:1c.3 PCI bridge: Intel Corporation 8 Series PCI Express Root Port 4 (rev e4)
00:1d.0 USB controller: Intel Corporation 8 Series USB EHCI #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation 8 Series LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation 8 Series SATA Controller 1 [AHCI mode] (rev 04)
00:1f.3 SMBus: Intel Corporation 8 Series SMBus Controller (rev 04)
02:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS5227 PCI Express Card Reader (rev 01)
08:00.0 Network controller: Ralink corp. RT3290 Wireless 802.11n 1T/1R PCIe
08:00.1 Bluetooth: Ralink corp. RT3290 Bluetooth
09:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL810xE PCI Express Fast Ethernet controller (rev 08)

Can it be fixed? It would be a great help.
Thanks in advance.

Zorin 15.3 is based on Ubuntu 18.04, so searching for anything with that version of Ubuntu is relevant and could possibly provide a solution.

You may want to try:

sudo apt update
sudo apt install ubuntu-drivers

and see if that allows for you to access bluetooth. If not, may try the following from :

Jeremy31 answered:

sudo gedit /etc/modprobe.d/blacklist.conf

and remove the following entries:

blacklist rt2800pci
blacklist rt2x00pci 
blacklist mac80211
blacklist brcm80211
blacklist cfg80211
blacklist wl
blacklist lib80211_crypt_tkip
blacklist lib80211

Save and exit gedit, then

sudo rm /etc/modprobe.d/blacklist-ralink.conf
sudo rm /etc/modprobe.d/blacklist-rt2800pci.conf
sudo sed -i 's/wifi.powersave = 3/wifi.powersave = 2/' /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf
sudo sed -i 's/modprobe brcm80211/#modprobe brcm80211/' /etc/rc.local
sudo sed -i 's/rt2800pci/#rt2800pci/' /etc/modules

Can't find those entries!!!

Then it's not blacklisted. That's actually a good thing.
Do you have wifi yet? Let me look into a few other possibilities.

yes i have wifi
but at the very first it was not working "drive not found"
then somewhere on internet i found "by desabling secure boot , wifi drive can work " ...and this worked on my hp 15 notebook
but bluetooth is not working

bluetooth setting look like this ....when my bluetooth speaker is on and not connected to any device and also my phone's bluetooth is on and visible to all devices
i tried above command ("sudo gedit /etc/modprobe.d/blacklist.conf")and found 2 of them in blacklist so i removed ...but then also not worked

Assisting someone else i found that the bluez in Ubuntu 18.04 and 20.04 can be buggy. To mitigate this try installing:

sudo add-apt-repository ppa:bluetooth/bluez 
sudo apt install bluez

Since Bluetooth is searching, the driver is working, so the new bluez may solve your issues.

1 Like

not worked , i installed bluez and it's repo😔
and logged out also ....but still same
Help me pls