HP 15z-eh000 Vega 8 - Kernel does not have the appropriate drivers


Some time ago I had problems with the screen resolution of my laptop that ended up solving in a not very correct way, then I have realized that I cannot adjust the screen brightness and that I cannot run complex graphics (games), since the My GPU drivers do not exist in the Linux kernel version 5.4, this because my GPU is from Q2 2020, I was investigating thoroughly and in several forums it is said that Vega GPUs need at least version 5.7 of linux for work properly, I tried to update the kernel to version 5.6,5.7, 5.8, 5.10 and 5.11 and none have allowed me to start Zorin.

What do you think I can do to solve the problem?

Thanks in advance.

PD. => G Translator :laughing:

Do you have the ‘noapic’ parameter added to grub?

Yes, I have added it and have done several more methods without any results, the screen brightness is always at maximum.

Very frustrating…

Secure boot disabled, APIC disabled… The kernel should be a Mainline kernel.

I have tried to disable / enable the secure boot without apparent result, it should be noted that for both cases I tried with and without the APIC parameter, I did the same with both versions of the Zorin kernel, 5.4.77 and 5.4.6

I also installed the private AMD drivers without success, once installed I could not boot Zorin, I tried several times to make sure it was not a bad installation. I tried about 5 times

:sob: :sob:

Have you reinstalled the open source xorg drivers and managed to get Zorin to boot in the meantime?

If his additional drivers section is locked on manually installed driver, he should input this command in terminal to get access to his Xorg driver.


sudo ubuntu-drivers autoinstall

Go back to Additional Drivers, select Xorg, restart computer.