HP All-in-One Printer / Scanner will not scan

Hello, folks.

I am new to Zorin. I am using OS 16.3 Core, updated to current as of 9/25/23. So far, I have enjoyed it. However, I have run into a problem.

My Printer Scanner unit, an HP Laserjet M28-31, will not scan. It comes up with "Failed to scan - unable to connect with scanner". I have tried using Document Scanner and XSane.

I have the HPLIP Toolbox installed.

The printer portion has been working (have not tested it since trying to get the scanner to work, though, so hopefully I did not mess that up).

Often, the scanner claims the HP unit is busy, unplugged or asleep (it is usually not)

Curiously, I have two things in the Settings > Printers area:

Screenshot from 2023-09-25 10-50-14

I hope I added the screenshot correctly. First time trying this.

I am not certain why I have two entries, with one saying it will not accept jobs and the other ready?

Please help me fix this situation. I nee the scanner for some important (not urgent, just important) work. Thanks!

After installing hplip, did you run hp-setup in terminal?
If not, can you run it and relay the output here?

It may help to run

sudo apt update && sudo apt upgrade

You can check the status of hplip with hp-check -r

You might run hp-scan in terminal to see if Document Scanner or Xsane is the cause of the issue.

Hello, thanks for the help!

After installing hplip, did you run hp-setup in terminal?
If not, can you run it and relay the output here?

Yes, I did.
Attempting it now (the printer uses a USB port, sorry I forgot that detail earlier), finds the same all-in-one printer/scanner unit, and asks if I want to install another print queue. I told it “no” and the program ended.

Running the update and upgrade commands updated some software, but I think it was graphic-card related. There was no change in the situation regarding the scanner part of the HP all-in-one unit.

After running the hp-scan, I got these codes

Selecting 0:

Num Scan device URI

0* escl:
1 hpaio:/usb/HP_LaserJet_MFP_M28-M31?serial=VNB3T07919

Enter number 0...1 for device (q=quit, =default: 0*) ?0
warning: No destinations specified. Adding 'file' destination by default.
Using device escl:
Opening connection to device...
error: SANE: Device busy (code=3)

Selecting 1 got me this:

Num Scan device URI

0* escl:
1 hpaio:/usb/HP_LaserJet_MFP_M28-M31?serial=VNB3T07919

Enter number 0...1 for device (q=quit, =default: 0*) ?1
warning: No destinations specified. Adding 'file' destination by default.
Using device hpaio:/usb/HP_LaserJet_MFP_M28-M31?serial=VNB3T07919
Opening connection to device...
error: SANE: Error during device I/O (code=9)

Now the fun stuff. I ran the hp-check -r run. The summary at the bottom says there are 12 errors and 1 warning. I have pulled out the errors for you to see. If you want, I can post the entire log of what I got, but I thought maybe start with this first and hopefully the solution becomes clear more quickly? Again, I am new at this OS, but I know long logs can sometimes be problematic to read.
The 12 errors are

error: cups CUPS - Common Unix Printing System REQUIRED 1.1 - INCOMPAT 'CUPS may not be installed or not running'

error: dbus DBus - Message bus system REQUIRED - 1.12.16 MISSING 'DBUS may not be installed or not running'

error: libjpeg libjpeg - JPEG library REQUIRED - - MISSING 'libjpeg needs to be installed'

error: cups-devel CUPS devel- Common Unix Printing System development files REQUIRED - - MISSING 'cups-devel needs to be installed'

error: cups-image CUPS image - CUPS image development files REQUIRED - - MISSING 'cups-image needs to be installed'

error: libusb libusb - USB library REQUIRED - 1.0 MISSING 'libusb needs to be installed'

error: sane-devel SANE - Scanning library development files REQUIRED - - MISSING 'sane-devel needs to be installed'

error: libnetsnmp-devel libnetsnmp-devel - SNMP networking library development files REQUIRED 5.0.9 - MISSING 'libnetsnmp-devel needs to be installed'

error: libcrypto libcrypto - OpenSSL cryptographic library REQUIRED - 1.1.1 MISSING 'libcrypto needs to be installed'

error: python3-pyqt4-dbus PyQt 4 DBus - DBus Support for PyQt4 OPTIONAL 4.0 - MISSING 'python3-pyqt4-dbus needs to be installed

error: python3-pyqt4 PyQt 4- Qt interface for Python (for Qt version 4.x) REQUIRED 4.0 - MISSING 'python3-pyqt4 needs to be installed'

error: python3-devel Python devel - Python development files REQUIRED 2.2 3.8.10 MISSING 'python3-devel needs to be installed'

The warning messages are:

warning: Failed to read /etc/cups/ppd/HP_LaserJet_MFP_M28_M31.ppd ppd file
PPD Description:

Printer status: printer HP_LaserJet_MFP_M28_M31 is idle. enabled since Mon 25 Sep 2023 10:11:42 AM MDT

warning: Printer is not HPLIP installed. Printers must use the hp: or hpfax: CUPS backend for HP-Devices.

So, am I missing something or several somethings that might correct this issue?

Again, thanks for the help

Can you please try:

sudo apt install --reinstall hplip hplip-gui

It looks like HPLIP package did not resolve dependencies.

Had a search here:


Can't find M28-M31 but lots of different M28 models.

Looks like you need minimum of HP-Lip 3.18.4 or possibly 3.19.12.

See also:

Out of curiosity, have you tried running Document Scanner application in Zorin?

If you are still having issues you could see if VueScan sorts you out. I opted to pay for the Pro version as you get all the bells and whistles like a Windows Scanning interface:

1 Like

Hello, Aravisian and Swarfendor427,

Okay, unfortunately still not coaxing the scanner to work. I did double-check to see if the printer component still works. It printed just fine, no problem. So, whatever is going on, it seems to be isolated to the scanner component of this machine.


I tried the reinstall suggestion. Unfortunately, the same results on both Document Scanner and Xsane.

I rebooted the machine after the reinstall and tried again. Same unfortunate results.

The hp-scan still giving off errors as well.

I re-ran the hp-check -r and got the same 12 errors, but a new warning (see below):

warning: zorin distro is not found in AUTH_TYPES
\Gtk-Message: 14:48:23.339: Failed to load module "canberra-gtk-module"
warning: unknown-16 version is not supported. Using unknown-0 versions dependencies to verify and install…

Again, I am new to this OS but that seems a bit more alarming than just a warning to me?

Is AUTH_TYPES some sort of authorization I need to set on the computer for it to talk? I know I had to go through some “fun” to get a driver installed recently because the software was complaining about a missing driver. Maybe something got tangled up when I did that?

Hello, Swarfendor437

In regard to VueScan, it did not find the printer / scanner unit either. I searched the supported units and it was not listed. Too bad, honestly, because I looked at it early on and it looks like a nice software package. Not giving up on it (yet), might find a way to adapt it at some point once this problem is solved (or use the list of supported printers as another data point in purchasing a new printer and/scanner one when the time comes).

As for the link regarding supported machines, I searched and confirmed it is not there. Nevertheless, I did bookmark that link for future reference and data points for new printers / scanners. Thank you for providing it.

I have tried running both the Document Scanner and the Xsane scanning software. Neither one is working.

So, another question comes to mind. How can I find out what hplip version I have on this machine? I would presume it is updated to the latest model, but with this situation, I am not taking anything for granted at this point.

This is just a warning about sound notifications. It can be ignored, or you can be rid of it with

sudo apt install libcanberra-gtk-module libcanberra-gtk3-modul

The hp-setup command should have shown that.

This is a message from hp-plugin, when it tries to access scanning using Root Privileges.
Software installed by the user as root will get installed to /usr/share directory.
So, checking /usr/share/hplip/base we find a file password.py we find this list:

AUTH_TYPES = {'mepis': 'su',
              'debian': 'su',
              'suse': 'su',
              'mandriva': 'su',
              'fedora': 'su',
              'fedora28': 'sudo',
              'redhat': 'su',
              'rhel': 'su',
              'slackware': 'su',
              'gentoo': 'su',
              'redflag': 'su',
              'ubuntu': 'sudo',
              'xandros': 'su',
              'freebsd': 'su',
              'linspire': 'su',
              'ark': 'su',
              'pclinuxos': 'su',
              'centos': 'su',
              'igos': 'su',
              'linuxmint': 'sudo',
              'linpus': 'sudo',
              'gos': 'sudo',
              'boss': 'su',
              'lfs': 'su',
              'manjarolinux': 'sudo',

We can add Zorin OS to it by dropping one line and adding:
'zorin': 'sudo',

1 Like

Hi, Sorry you are not having much success. I've always preferred Canon inkjet All-in-ones. My current one is a Pixma TS-8151 and works with Document Scanner with Zorin 16 out of the box and absolutely no issues with VueScan. Canon Laser all in ones if that is your preference have dedicated Linux drivers. At work I even got a Kyocera big MFD connected to a notebook running Zorin 15 (which also had dedicated Linux drivers). From what I have read elsewhere, HP seems to be dropping support for Linux in general.

1 Like


Okay, so perhaps it is the lack of an authorization? If so, How do I add Zorin to the list to see if it is a root-lever permission matter? I suspect I will need to do this under root administrative authority, but I do not know how to do that.

Also, I noticed the version of the HP-LIP I have is 3.20.3 and the latest one I can find is significantly higher than that (3.23+). Maybe try that next in case the authorization changes fail?


Nice to know about those devices. I have made a note of them and will keep them in mind when the time comes to get a new machine.

Again, thanks for the help. It is appreciated :slight_smile:

Badger, I addressed this and how to proceed in the post above with this content:

We can fix that. I am assuming you are using Zorin OS Core (your profile does not have your Zorin OS Edition filled out).

First, open a terminal, then elevate to Root.

sudo -i

Now, in the elevated terminal prompt, launch your file manager:


Your FilesNautilus file manager will now be running with admin privileges.
You can also add the ability to do this in GUI using the Right Click > Open as administrator.
Install the Nautilus-Dmin package:

sudo apt install nautilus-admin

Relaunch Nautilus - and now you should have the ability to right click in a window, select "Open as Administrator" from the context menu and perform any actions needed in Root.

To get to Root in Nautilus:
In the left pane, select "Other locations". Then, in the right pane, select "Computer".
Now you will be at the Base of the Root File Tree. Double click the /usr folder, then the /share folder. Scroll down to the /hplip folder and open it. Then, finally, the folder named base.
Right click the password.py file in that folder. Select open with text editor.
Add 'zorin': 'sudo', at the bottom. It should look like:

              'boss': 'su',
              'lfs': 'su',
              'manjarolinux': 'sudo',
              'zorin': 'sudo',

once you have pasted in the line for Zorin OS.
SAVE the file when complete.

My apologies for not updating this sooner.

Unfortunately, the scanner portion of the unit still does not work. Due to time constraints, I have ended up getting another scanner to do the job.

I also did a deeper search into the available drivers for this particular unit. I did not find any specifically mentioned at the HP-recommended site, although the printer part still works.

Still, the unit has been a good unit for me, so I am not giving up on it. I hope at some point a way to fix it will be found.

Thanks for trying, folks. I do appreciate it. I wish the results has been better.

Have a great day.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.