HP Deskjet 710C prints but

The two buttons on the driver, head cleaning and self test page dont work. They send a job but no output. The foomatic driver hasn't been updated since around 2000. Any fixes?

You might try the most up-to-date HPLIP (3.23.12):


hplip/focal 3.20.3+dfsg0-2 amd64
  HP Linux Printing and Imaging System (HPLIP)

And foomatic:

Also, apparently that printer requires pnm2ppa:
Your printer is specifically listed in the drop-down list on that page.
Here's the pnm2ppa file for your printer, generated by the site above:

sudo apt search pnm2ppa

printer-driver-pnm2ppa/focal 1.13+nondbs-0ubuntu6 amd64
  printer driver for HP-GDI printers

sudo apt install printer-driver-pnm2ppa


1.13 Of pnm2ppa is already installed. As for HPlip I dont think it supports my printer. Will check again. Well tried the latest Hplip and it just errored out with too many errors to mention when I ran hp-setup. Rolled back with timeshift and tried hp-setup again but it doesn't support parallel ports. Think I ran into this problem on Windows.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.