HP G6, DVD Drive

Hi i have installed zorin os, onto my hp pavilllion g6 laptop and tried to put a few of my software cds, or even dvds, but zorin wouldnt even pick it up, i even tried blank cds, can you help me please

Can you try:

sudo apt install libdvd-pkg

sudo dpkg-reconfigure libdvd-pkg

Hi it did not work, is there anything else i can do

Is the drive itself not being detected? OR is it detecting the drive, but not mounting the media?

It has detected the drive as i checked in terminal, but its not mounting the media or the drive being visible on the file manager

It may be easier with a guide:

You want to check your ID for your dvd drive.
Commonly, it is sr0
For me it is:
lrwxrwxrwx 1 root root 3 Mar 22 16:39 cdrom -> sr0

lrwxrwxrwx 1 root root 3 Mar 22 16:39 dvd -> sr0

So for me,

sudo mount /dev/sr0 /mnt/cdrom

would work. Try mounting yours based on the above guide and see if it is recognized by system and by file manager.
If that works, may need to add it to Automount.

1 Like

It says mount: /mnt/cdrom: no medium found on /dev/sr0

Can you run the following in terminal, then paste the output here?

inxi -Fxz

You may need to add your user account to the cdrom group:


Replace ($USER with Your Username)

sudo adduser $USER cdrom

Most often, this is a hardware issue. Can you check the drive itself?

1 Like

Ive checked the drive myself and it is all connected and working, but ill give the code a shot

For inxi -Fxz

It says Drives

ID-1: /dev/sda model: Hitachi_HTS54757 total size: 750.2gb

And it has a lot of info about my laptop

And for adding user its says "user" is already a member of "cdrom"

1 Like

I understand if you are protective about your laptop information, but inxi-Fxz is used to provide that info for troubleshooting. If you prefer, you can PM the output rather than posting it publicly.
I need to drive my son to the airport - back in about an hour and fifteen minutes.

1 Like

Ok i will pm you the info

How do i pm you

<< Click my User name or Avatar.

I did but it doesnt say message or anything it just comes out with your stats, if you pm me ill reply to you

Can you run in terminal:

sudo apt-get install ubuntu-restricted-extras

Then, in your file manager, navigate to /usr/share/doc/ and check if you have libreaddvd4 or libreaddvd7 or libreaddvd8... Whichever it is- that is the one to use. On mine, it is 7, so I put libreaddvd7 in the command below. Replace the number 7 with whichever highest number of libdvdread you have.

sudo /usr/share/doc/libdvdread7/install-css.sh

1 Like

Will do when i get home

1 Like

It says on the 2nd code, sudo: "the code line you gave me": command not found

Ok, that is actually normal- that means the first command here:

sudo apt install libdvd-pkg

should have solved that, then.

But... It did not.

The mounting above and installing the dvd pkg's really should do it if it is software side. I am at a loss, and your inxi did not reveal any other errors or missing pkgs.
Maybe firmware update?