HP Network Printer

Hi all,

I have a network HP printer OfficeJet_Pro_6970

I read online that HP drivers should be all pre installed in Zorin OS (the printer is a 2018 or so model)

When I log in it detects it, but I am not able to print on it

Then I read this Printers and Scanners - Zorin Help
so I install the latest hplip (surprising it was not the last version :open_mouth: )

sudo apt update && sudo apt install hplip-gui

and I install the printer using the hplip gui tool and it works.

But now everytime I log in zorin still detects the same printer again (which does not work and I deleted), so I always have 2 printers in the list. How can I stop Zorin detecting the printers?

Thanks in advance,
OcirneMat

My workaround has been to install the printer I want manually, and select a different name for it. That way I know which of the 5 LaserJet Pro MFP printers on the network I want :wink:

But getting rid of the "automatic" printers would be nice...

Thank Mikkel

Also I do not understand why the automatic one still does not work even if the drivers are already in the kernel.
Mystery of Linux :-S

You can install the Extensions app from the software center, and disable "Zorin Printers" from there, I assume that should do the trick

Hi TGRush, thanks for the tip
I disable Zorin Printers, reboot.. but unfortunately the problem is still there :frowning:

My quick google search session some days ago suggests it's a standard CUPS feature - not something Zorin specific. I didn't have time to try the different suggested fixes...

Open a terminal and enter:

sudo system-config-printer

You should get the same interface as you would normally but you are now running it as 'root'.
Delete the duplicate printers leaving the one that works.
Close the Printers dialog, exit the Terminal and reboot - has it worked? Just wondering - don't have this issue as not currently using Zorin as my go to.

Thank Swarfendor437,
Thanks for the support :slight_smile: I did run

sudo system-config-printer

But I find only 1 printer (the correct one), so everything is ok.
However in Settings-Printer I still find the second printer too (not correct).. I delete it.. and after 1 min it comes back

I've just thought of something, but if you don't want to do it as everything is working OK I will understand. One thing I have noticed from personal experience is that if you turn the printer off, turn the wall socket switch off/and unplug from the wall, the computer will not see the printer at all. I only discovered this with my Canon printer and a similar thing happened at work with an HP wireless workstation printer. I advised the team members by all means to switch the printer off at the end of the day, but never turn off the switch of the socket or unplug the printer. They had been switching the socket off and the iPads could no longer see the printer so it had to be installed again, also with Notebooks (Laptops).

Hi @swarfendor437
thanks a lot for the good input.
For me yes, if I switch the printer off (even without unplug from the wall) the "wrong" printer disappear.
However this is unfortunately not a solution for me as when I want to print I need to switch it on and the "wrong" one appear again and it make always confusing to select the correct one.
Also I have a scanner too in the HP printer (it is an all in 1 solution). So I need to have it on when I scan

  • You can create prints with two sides using HP Officejet Pro 6970 Setups with the driver software available for Windows. It is essential to load enough paper into the input tray to finish the printing job.
  • Choose the document you wish to print. Click File and select Print to open the print dialog box for your system. Select the printer you want to use from the results for printers.
  • Select Preferences , and then choose the Shortcuts tab for printing. If the tab isn't accessible, click the features tab. Select the Two-Sided printing option.
  • Choose the desired Flip option in The Print on Both Sides option. Printouts can be made in booklet form by selecting an option called the Flip On Long Edge option Read More.

Hi @Arevak1 ,

My issue is not about to print 2 sided, that works perfectly. The problem is I see the printer tiwce:

  • One from the drivers I installed
  • One from the ubuntu driver autodetection

I wanted to avoid to install the driver and just live with the autodetection, however the autodetected printer does not work unfortunately
So I installed HP drivers, but linux does not recognize that the printer detected is the same of the one I installed :sob:

1 Like

One solution (not optimal) i found here
https://forums.linuxmint.com/viewtopic.php?t=277091

Is to just remove the autodetection

sudo nano /etc/avahi/avahi-daemon.conf

In that file

change “use-ip4=yes” to “use-ip4=no”
change “use-ip6=yes” to “use-ip6=no”

That works, but it is not ideal: i disable the detection of other printers.

Do you know if there is a way to tell linux that the printer I installed with the HP Drivers is the same of the one linux detects automatically?

Thanks in advance,
OcirneMat

Has a good and proper solution be created/discovered?
I read in another thread that using the wifi option with no USB connection corrects the problem. Have you tried that?
I am having the same issue with my father's system and it seems totally unnecessary....when he needed a new printer I got him another HP since they had always been so easily compatible with linux.....but, this has been an issue with both Pop! and now Zorin 16 Pro.......so that tells me that it is an ubuntu problem, not that knowing that helps the status of any ubuntu based distro :roll_eyes:

1 Like

Unfortunately not, beside disabling the discovery by network

change “use-ip4=yes” to “use-ip4=no”
change “use-ip6=yes” to “use-ip6=no”

I've noticed this issue on many distributions and believe it must be something to do with kernel updates. When your printer gets 'autodetected' you should also see somewhere that it is 'driverless' - because it is - all that GNU/Linux is doing is correctly identifying the hardware, and putting an icon in Print Settings - then you try and send something to print and nothing comes out of it. One of the things I have thought about recently is to disconnect the USB cable to my Devuan box so it only has the wireless Printer showing (or so I thought - deleting the .local printer kept coming back. After some research I issued this command in the terminal:

sudo apt-get remove cups-browsed

For ubuntu derivatives you may have to do something with systmctl:

In respect of autodiscovery of network printers: