HP Officejet 9010 printer setup/can't detect

I'm trying to setup my printer via direct USB connection. With my Pro 16.3 version I first tried going through settings and it did add my printer. My printer shows up with the job I'm wanting to print. But it wouldn't print. I tried updating the driver, no luck.
I installed HPLIP and it can't discover my device via USB connection. So it said to go back and change discovery options. I changed the discovery option to network/ethernet/wireless. This brings up the message that it can't detect printers in my network. It says it may be a firewall and to go to http://hplipopensource.com/node/374. This page says "Page not found."
Most of the search options I found here were from a couple years ago.
Is there anything new to help me out?

Have you removed the one added first before trying again after installing HPLIP? Might hold residual info / config that may hinder connection.

With the USB plugged in, does it show up in lsusb (terminal)?

Wireless - might be a direct WiFi connection it's referring to, probably not. This was what it was supposed to direct you to, the download link to HPLIP - you've got that already, so no need.

I don't have any HP drivers installed myself on Core 16.3 - I am hosting it through a Cups server on my network.. What Cups version do you have installed? - should display this if you have Cups installed.

No the printer doesn't show up in the terminal.
I have removed it and added it and removed it...
I didn't get that page you're referring to. It didn't look like that.
Now I did get my printer to work one time but I ran through multiple steps to do it and I can't remember how it was achieved. I'll try that page's download link though.
The HPLIP setup utility version was 9.0. I'll check the Cups server version.
And, the website with the numbers brought up "Unable to connect" problems with page message.
I'll check around and let you know if anything works.

Does not sound too good; but, you were able to get a test page / print completed?? The 127 number is your local machine address, home address is the :631 bit is for Cups, that's the port that it communicates over. Which sounds like Cups isn't installed - that could very well help what's going on. You can check this with either Synaptic package manager, or through terminal with apt search cups and should [installed] if in fact installed. I would definitely check this.

I have the available HPLIP version through apt - version 3.20.3, but no specific software related to HP or drivers. I don't on the hosting device for the network printing - Raspberry Pi 3B+, just Cups. Unrelated - but you might also need drivers we'll see - but didn't show in lsusb output? :thinking:

Well speaking of Synaptic package manager. In the list I doubled clicked on it and it won't open. Just a spinning dot and nothing. That issue to be addressed later I guess.
Then I went to the HPLIP download page you gave me and I ran the file which opened in the text editor and after showing 698 lines of code it says there was a problem opening the file and to try different character encoding.
Yes, I was able to print a page before.
I checked for cups in the terminal and it comes up with some green lines that are: SSVNC, System config printer, system config printer common, system config printer udev and the last green line is yasat.

So, the downloaded file is a .run file - you will need to change the permissions of the file to allow executing to install. It's likely you won't need this - let's start with:

Screenshot from 2023-11-03 23-31-03

Do you have the [installed] status for Cups like the above screenshot? There was mention of this being in the list but, no mention whether installed.

Are there any software updates available through apt update or Software Updater? It would be a good idea to see if any updates are waiting for installation.

Some digging on HPLIP - there is an hplip-gui package that may be of help. There also may be something with sudo hp-setup -i - was reading some resolutions from this and USB configuring, you may need to have HPLIP configured before using the printer :person_shrugging: - something I've really never had to do before..

But, start small; Cups: is it installed? Then with the printer in USB, running the above hp-setup command as it may just need a configuration command to get going. I'm still puzzled how it was able to print a page but not listed in lsusb - some screenshots of your outputs / screen would be awesome :+1:

1 Like

There has been progress!
There are two ways to connect the usb to the printer. One is a usb port on the side of the printer and the other is by using the cord it came with and it plugs into a square shaped port in the back.
I tried the cord that plugged into the back (this I used before I remember now) and the device was found through the HPLIP toolbox. It brought all of the info up on the printer through the device manager of HP and where is says to run a test page I did that but it wouldn't print. It said it couldn't communicate with the printer.
I went into my files and tried printing a txt file document and it printed.
I ran lsusb again and my printer shows up.
So, I think it's fine right now.
I have to figure out how to do the screenshots. I know how to do them for getting regular screenshots but I don't know how people put their lines of code into this area.
And, when I looked into the properties and things on my printer I saw cups there so I think cups is fine.
This is my attempt at trying to communicate things to someone with an advanced computer mind using my simple, albeit probably painfully so on your part, way of telling you what's happening.
Thanks for your info and help again!

1 Like

I believe only one; the USB-A port is for an external storage device to print directly from the device if you have pictures, documents, etc. The 'square shaped port' is actually the USB-B port, or the common printer / data port on printers now. Long, long ago in a galaxy far far away there used to be a huge 25-pin parallel connectors for 'standard printer comm' - thank goodness that's GONE! :joy:

But yes, please keep the USB-B connector in :wink: that should fix all the issues.

BTW - do you have a USB-A <-> USB-A? Like (disregard the blue and Super Speed emblem):

Bah, don't worry about it - there are tons of awesome brainpower here (forums), I've found! I aim to help - not belittle! :grin:

Not too bad - there's a screenshot tool almost exactly like the Windows 'snipping tool' just called screenshot in the apps menu, or start menu. Of course, you can always do a PrintScreen, should go to your Pictures folder in home. Then, in the response bubble at the top - there's a toolbar, one icon looks like a little picture icon, click that, and it will open a file manager window. Navigate to Pictures or where the screenshot / photo is, select, upload, done! :sunglasses:
Screenshot from 2023-11-04 00-16-10

To get stuff to look like this, you can use the backtick button or, the kind of backwards apostrophe below the tilde - enclose text in that like with quotation marks, and you get this! Lots of times line from terminal will end up there for ease of differentiating between conversation text and command line text :grin:

You'll get the hang of it! Just don't be afraid to ask - I guarantee: if it's anything related to self-destruction related issues of OS, I've been there :rofl: But definitely here to help!

Just a footnote. The Linux kernel can now identify printers connected to the machine, so even if you delete the first one that got installed by the kernel it will always come back in printers but won't be set as default. A few years back it would announce the discovered printer as driverless, hence the lack of being able to print.
Whatever printer you wish to install I learned from the Pear OS forum you should always run:

sudo system-config-printer

This always pulls up the same interface as launching Printers in Settings but greater control as you have launched it as 'root'.

So the first step is to install the drivers, then issue the sudo command above and when you go to select manufacturer then click on next to get list of all models your HP deskjet should be listed.

Once printer has been setup, use this guide to prevent autodiscovery returning driverless printer:


Thanks for that! Somewhere along the line of countless screens I went through to get my printer to work I came to a place that had that option. Thinking this could be the problem of my printer not working I tried but it said my printer didn't need any driver update. I couldn't find it again probably to save my life though. It's all a blur now!

I ordered the official HP Officejet 9010 compatible cord which is called "USB Printer Cable High Speed USB 2.0 A Male to Type B Male Printer Scanner Cable Cord Compatible with HP". I needed a longer one so I don't have to jump up and down going to my printer when I want it to print.
The one you show is what I had plugged into the side of my printer which didn't work. The one that works has a square opening on one end.


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.