HP Pavilion Laptop won't wake from sleep with Zorin OS 16

Hmm I can't actually extract the Bios_update.exe to get the .bin files. I get an error that Cannot open file as archive.

I might have to put windows back on the laptop just to run the firmware update directly :frowning:

If that is a viable option... then...

I just tested this, to be sure and ran into the same problem:

7z e sp133136.exe

Worked and yielded BIOS_update.exe. But that could not be extracted. I am not sure what is going on there.

Well I managed to get the BIOS update to install but I'm afraid the wake from sleep functionality is still not working correctly. The machine is just unresponsive to keyboard/touchpad to get it to wake (the power led just keeps pulsing).

I've got the latest syslog entries after the bios update:
SYSLOG part 1
SYSLOG part 2
SYSLOG part 3

I did notice on updating the OS via the system manager it reported missing modules related to the GPU and something about boot (I don't know how to capture this information as it just showed up in the details section of the software update center)

1 Like

I'm sorry but to save us scrolling and searching, can you please reiterate what Graphics card you are using and what kernel you are on?

uname -r

sudo lshw -c video

uname -r: 5.11.0-38-generic

lshw -c video:
description: VGA compatible controller
product: Renoir
vendor: Advanced Micro Devices, Inc. [AMD/ATI]
physical id: 0
bus info: pci@0000:04:00.0
version: c2
width: 64 bits
clock: 33MHz
capabilities: pm pciexpress msi msix vga_controller bus_master cap_list
configuration: driver=amdgpu latency=0
resources: irq:52 memory:d0000000-dfffffff memory:e0000000-e01fffff ioport:f000(size=256) memory:fe300000-fe37ffff

There you go; thanks again for looking into this.

I would encourage you to roll your kernel back to a known working and AMD supported kernel.
We can try the 5.8 first and if that fails, the 5.4...

sudo apt install linux-headers-5.8.0-63-generic linux-modules-5.8.0-63-generic linux-modules-extra-5.8.0-63-generic linux-image-5.8.0-63-generic

Once installed, reboot, then from grub, tap the tab button to see Advanced options for Zorin. Move to the 5.8 kernel and boot into it.
Test the system and relay the results.

1 Like

Woohoo! I can report success using the 5.8.0-63-generic kernel!
So I guess something got introduced between 5.8.0-63 and 5.11.0-38 huh?

Thanks for your help with this; May I ask is there a way to default the Grub launcher to use the working kernel so I don't have to select it each time please? The girlfriend is going to be using this laptop for work sometimes and she won't have the patience for going through advanced options :slight_smile:


A regression - something got removed. :expressionless:

Yes. You can remove the 5.11 kernel completely

sudo apt remove linux-headers-5.11.0-38-generic linux-modules-5.11.0-38-generic linux-modules-extra-5.11.0-38-generic linux-image-5.11.0-38-generic

Once done, open Synaptic (if you do not have it, sudo apt install synaptic)
Then click the search button.
Search for:
Tick all the boxes on the ones that You Have Installed.
Now go to the menubar and select Package and move down to Lock Version and select it to Lock the kernel to its current version.
That will prevent it from Upgrading to the newer non-working kernel.

Hmm...I ran the commands and locked the values in Synaptic

However the behaviour goes right back to the way it was before (Not waking). If I run the uname-r command it reports back as 5.11.0-38. If I reboot again and check the advanced settings it still lists 5.11 and 5.8 as options.

Not sure why that is given it's listed as removed if I try to remove it again :confused:

dpkg --list | grep linux-image

Find the remaining kernel, then sudo apt remove... any above 5.8

dpkg --list | grep linux-headers

Same as above

dpkg --list | grep linux-modules

Same as above... Once you have cleaned out all remaining pieces of 5.11, please reboot and test.

(I guess you could also do the same in Synaptic - by searching for 5.11.0-38, selecting any as "remove completely" and then clicking apply.
It just now occurred to me. I use the terminal for most things.)

Well this is bizarre; after listing and removing all those components Terminal now reports that I'm running the 5.8.0-63 version on boot up but the sleep > wake issue has returned.

I tested it numerous times using both the power button (set to sleep) and closing the lid + walking away and it worked when I had to select which kernel to run :confused:

It was a short lived success... but a sweet one. I will always remember it...


Indeed. I will treasure the memory :slight_smile:
Should I try putting back in 5.11.0-38 and see if that makes any difference?

You could, just to see if it duplicates the Suddenly working when selecting the kernel or not...

Other than that, my brain blew a fuse. I will try researching the issue a bit.

If you thought that was bad; I just put 5.11.0-38 back in and low and behold the sleep function is working correctly again when you select to boot from 5.8.0-63 on grub :confused:

It acts as though there is a cross dependency; which makes no sense to me lol

Agreed, it doesn't.

Let's set grub to boot from the last Kernel you selected. Boot into 5.8, then open a terminal and

sudo nano /etc/default/grub

Then hit enter to make a new line and add this line into that space: GRUB_SAVEDEFAULT=true
Hit ctrl+x to exit, then the y key to say yes to save, then the enter key to save as current configuration.

The terminal will revert to normal- run sudo update-grub

Then reboot and test...

Okay I've got another log of 'that's weird' to add to the pile of 'why the heck is that happening'

I made the changes to grub and updated it. Rebooted the machine and selected the 5.8 kernel under advanced. Verified it was running 5.8. Tested the Sleep > Wake (multiple times) and everything was fine.

Powered off and Powered on the device. Let the timer run out so that the system would automatically boot the default selection in GRUB. Verified that the version running was 5.8. Tested Sleep > Wake. 1st time it worked. 2nd time it woke up then immediately went back to sleep so I woke it again. 4th time it went to sleep and never woke up.

Powered off and manually selected 5.8. Retested Sleep > Wake multiple times. No problem.

What Is Happening Steve Carell GIF by Saturday Night Live


You may need to tell your girlfriend to get used to booting from Advanced Options and double check your pre-nup.


Well the good news is it also seems to work if, on bootup, you leave the selection (which is already on Advanced) alone and just keep pressing enter (5.8 gets selected automatically). So as a workaround it isn't terrible but I do hope this gets addressed.

Since 5.8 is being selected now should I leave those synaptic files locked? Or is it better to let the system update things and just let Grub select the 5.8 on bootup?

Spoke too soon again!
LOL! So it also seems there is a difference between closing the lid and pushing the button (set to sleep). If I push the button after 1-2 more sleep > wake tests everything locks up and the system stops waking.