HP Spectre x360 - Can't install

Can't seem to get Zorin 16 pro to install, getting ACPI BIOS Error could not resolve symbol, but Ubuntu 21.04 installed 1st time no problem.

Support not responding to my requests for help - can anyone point me in the right direction?

I am not sure which previous support request that you put in on the forum, unless you mean, that you used your PRO installation support, in which case, answering that is the job of the Zorin developers.

I assume that after you downloaded the Zorin ISO, that you checked the SHA256 HASH for ISO integrity correct? And I assumed it passed correct?

I hope you didn't use Balena Etcher to make the USB burn, its shown itself to be greatly unreliable to put it mildly. For already Linux users, I recommend using Popsicle to make the burn.

If Windows user, I recommend Unetbootin, or Rufus to make the burn. Another question, is SECURE BOOT and FAST BOOT disable in the BIOS? It needs to be, just so you know.

ACPI errors are generally power management based. Maybe there is a toggle setting in your BIOS that you need to throw to make it work. You are still entitled to professional support from the DEV's being you are a PRO owner.

As such, I will be bringing their attention here, since you are a PRO owner.

@AZorin @zorink

1 Like

Many thanks for your reply. Yes, i went through the link in the serial number email, but sadly no response after a few days - thanks for push it on for me.

Yes for ISO and HASH check.
No, i burnt using Rufus3.19 on Win10
Yep Secure boot and fast boot off.
Didn't know about the power management, i'll go back and take another look

Really appreciate your attention
Sleepii/

2 Likes

Have you tried any acpi kernel boot parameters?

Thanks to you both for your help. After much tinkering with BIOS settings i have stumbled into a resolution. I'm not sure which step i tried sorted it, but here are the things i did;

I had all the settings above (secure boot & fast boot off, legacy on), but still had TPM enabled. Apparently v16 should support TPM, but i turned if off, cleared the HP security keys. Then i downloaded a new ISO image, and burnt with Popsicle (on another Ubuntu laptop), booted from it, and it installed!!!

Not sure which of these was the issue.

Then, my Win11 dual boot partition became corrupted with the "preparing repair" loop, none of the windows repair tools could resolve. Turned TPM back on, Legacy off, reloaded HP security keys - but Win11 still corrupt and cannot be repaired - even restore Win11 will not work - cannot restore the bootrec.

Turned TPM off, legacy back on, secure boot off, cleared security keys. Then did a full new Zorin install wiping entire SSD. Installed and loaded perfectly.

I haven't gone through all the hardware driver issues yet, but i'm satisfied the install is working perfectly, and is running 80% as i expect. For my Windows partition requirement, i'll run in VirtualBox.

I know this port is long and mundane - but i thought if i tell you want i did, it may help others that run into similar issues.

Zorin support won't be needed now - so if they read this, thanks, i'm all sorted.

3 Likes

Glad you got it working and welcome to the forum! I have the same laptop as you and am so thankful I didn't run into an issue like that! You're a trooper, way to hang in there and troubleshoot.

See you around!

2 Likes

I selected your own posting as "solution" and marked the thread as solved :ballot_box_with_check:
This will help the future visitors to this forum to find the answer they are looking for.

2 Likes

A post was split to a new topic: Difficult installation of Zorin OS on HP Spectre360