Hub 8-0:1.0: config failed, hub doesn't have any ports! (err -19)

Yes, as sound may be routed either through the processor or through the GPU.

I do not mean that your current drivers are not working. But they may not be fully working. It is worth checking.

1 Like

Understood. I ran the deb file you suggested and it successfully installed it. I ran the software updater, but it says the software is up to date. Anything else I should do?

The next step would be to test the results against the nomodeset parameter.
Please do not forget that you can revert the change using Recovery menu if needed. So if things appear sticky, no need to panic.:wink:

Your patience is admirable. Most users only need to install and use - they do not have to argue with their computer to get it to work...

1 Like

Ok, so I edited the GRUB again, back to "quiet splash" and restarted the computer.
Same error hub 8-0:1.0: config failed, hub doesn't have any ports! (err -19) and still freezing.

To be fair, at this point I know it by heart :sweat_smile:

Thanks, I guess :sweat_smile:! I have been using Zorin OS on an old laptop and really enjoy it. And now that I could finally build a good machine I just want it to work really bad.

1 Like

Good. Because now you have to go put the nomodeset back in. (sigh)

What is bothering me about this... is that the error is directly calling the USB port. It does not mention graphics, at all. Are you using a USB cable or Thunderbolt dock to connect the monitor to the machine?

1 Like

I am on it!

No usb cable, no dock.
Only things connected:

  • mouse usb dongle
  • keyboard usb dongle
  • ethernet cable
  • and an hdmi to vga adapter. I am using an old monitor, as you may see in the pictures from previous posts. Could be it?

I used an HDMI to VGA adapter when I hooked up one of my old monitors. The effect was that it mostly worked and I did not get any printed errors but... If I used any theme that made use of color #555, it would blank out the monitor. Very strange.

If the monitor is sufficiently, old, it is possible that it may be giving you trouble. And the adapter increases that.

Hardware contains its own operating system. Your O.S. that you interact with does not govern the hardware or run it; It communicates with it. The hardware governs itself. This communication is provided by Drivers.
Your Graphics Card drivers are tasked with the job of communicating with Monitor Operating Systems and if the monitor is old enough to have been dropped from support, I can see how that may be an issue.

1 Like

Bad news. I plugged the PC to my relatively new TV with only the hdmi cable, no adapter. Edit the GRUB back to "quiet splash", sudo update-grub, restarted the PC, crossed my fingers...and same error and freezzes. :smiling_face_with_tear:

Worth noting something that I did not realize before: the FAN CPU goes VRUM when the error appears, only to slow back to normal shortly after.

Can you remind me of which kernels you have tried or are using?

1 Like

Currently using 6.3

Can you unplug All USB Devices, including keyboard and mouse and try a test boot?
If it does boot, you can try plugging in USB devices one at a time, testing boot each time.

1 Like

Ok, so I unplug all USB devices, including keyboard and mouse. In boot, AMD shows a message of no keyboard but still boots.
The error message appears in the begining, but did not freeze this time and boot sucesfully!

One more time, now with keyboard in a different USB port.

Error message, no freeze, succesfully booted.

Now, both mouse and keyboard on different USB ports.

Error message, no freeze, succesfully booted.

So, I got bold: both mouse and keyboard on the previously ports when the boot was freezing.

And it also booted succesfully!
I went to GRUB just to make sure, and there it was "quiet splash". So we managed to succesfully booted without modeset.

Now, some bad news:
Wi-fi and bluetooth still not functioning.
Error message at the start still appearing.

Also worth noting: sound is working clean now.

You are still getting the USB error message, even with all devices unplugged or with them re-plugged in - but able to boot - correct?
In your BIOS Settings (accessible from boot, motherboard, usually F2), do y ou have any of the following settings available?

  • XHCI Handoff
  • EHCI Handoff
  • Legacy USB Support

Correct. Message still appears with or without usb devices are plugged or unplugged, but it does not freeze anymore. Both WIFI and Bluetooth also don't work. I was able to update my BIOS to the latest version today (1811), but nothing changed: error appears with our without usb devices plugged, WIFI and Bluetooth still does not work.

Yes, it has and is enabled.

No, there is no EHCI handoff.

It has, and it is enabled.

Can you try disabling it?
This will result in any 3.0 ports reducing to behaving at 2.0 speeds, but if you are only using them for keyboard and mouse, that is perfectly fine...
We just want to test if that has an affect on the error you are getting.

It is looking more and more likely like a faulty USB unit.

Done. Saved and exit. Restarted. Nothing changed, same error message, WIFI and bluetooth not working.

May as well make a note to re-enable that - just in case you need 3.0 speeds on a USB drive later...

1 Like

Ok, so I tested all USB ports with both an USB stick or USB device. All ports worked. The only exception was the port marked "BIOS" with the USB stick (keyboard or mouse plugged to that port worked).

You have a BIOS port?:expressionless:
The purpose of that port is for updating the BIOS using a USB stick instead of having to boot Windows...


That they are functional, does not mean that all is well. The error is being thrown. This can create a situation that a USB port is transferring information, but not configured correctly.