Hub 8-0:1.0: config failed, hub doesn't have any ports! (err -19)

Hi everyone,
I just installed ZORIN OS CORE 16.3 on my new pc, following all the steps on Install Zorin OS - Zorin Help.
But after successfully installing it, when I first boot it shows the error bellow and freezes:

hub 8-0:1.0: config failed, hub doesn't have any ports! (err -19)

My PC setup is:

AMD Ryzen 5 7600 3.8 GHz 6-Core
XFX Radeon RX 570 4 GB
Kingston FURY Beast 8 GB (1x8 GB) DDR5-4800
Kingston SSD Nv2 1 TB M.2-2280

I appreciate any sugestions to fix this. I have been using Zorin for the past 2 years on my old notebook and was really looking foward to use it on a new machine.

Are you using a USB Hub?
If so - Does it have its own power cord or is it drawing from the Computer Power supply?

I would try booting without the hub connected to test.

1 Like

I am not using an usb hub.
There are only the usb ports onboard and the usb ports in top of the pc tower (does this ones count as usb hub?)

No, a hub would be a separate peripheral device.
Can you please ensure you are connected to the internet on that machine, launch a terminal window and in it run

sudo apt update && sudo apt full-upgrade

Reboot and check for the error. If still resent, please relay the terminal output of

uname -r


dmesg | grep usb

1 Like

Ok, it is connected, but it is freezing in the error before startup. Is there a way to run terminal before start up?

Yes, there is. You can enter the Grub Menu, then select the Advanced Options for Zorin and choose the Zorin On 5.15.0-...(recovery)
This will take you to the Recovery menu.

Arrow key down to Enable Networking first to connect to the net. Back up to the Recovery Menu and arrow key down to Root - Drop to prompt.

From this prompt, you can run the commands.

sudo apt update && sudo apt full-upgrade

Test boot...if no good, return to the prompt and

dmesg | grep usb

You can take a photo of the screen if that helps you.

1 Like

Strange... usually it's an Nvidia card (it conflicts with an internal USB hub) that causes this, but you've got the AMD Radeon. And usually it'll boot despite the error.

First, ensure you've got the latest firmware (version 1811).

Pro-tip: Check in your BIOS / UEFI settings to see if it's got an update utility built-in... that's much easier than downloading the update and applying it outside the BIOS / UEFI settings.

After that, we'll troubleshoot more if the problem isn't resolved.

Typically, a 7000-series Ryzen CPU requires a 6-series kernel, so if the firmware update doesn't work, we'll give you the resources to update the kernel.

One other thing you can try:
sudoedit /etc/default/grub
-- or --
sudo gedit /etc/default/grub (if you don't have sudoedit set up yet in .bashrc)

To set up sudoedit, in .bashrc, enter the lines:

# Edit files by using sudoedit {/path/file}
export SUDO_EDITOR='/usr/bin/gedit -w'

In /etc/default/grub, edit the line:

... and include the following after the  =  sign and inside the quotes ( " ):
nomodeset nouveau.modeset=0 noplymouth

noplymouth disables the splash screen so you can see the logs flash by as it boots.

nouveau.modeset=0 might not be needed. Try it with and without.

Then issue:
sudo update-grub

Since your machine isn't booting, you can just edit the boot string from the Grub menu (right as the machine first boots) to include that nomodeset entry, then if it works, include it permanently in /etc/default/grub as shown above after you've got it booting properly.

Sorry, it took me some time to understand how to enter Grub Menu, but I did it!

Done, and when I run the system from the grub it boots. But when I restart, it shows the same error plus:
pci 0000:0c:00.0: failed to read data
usb usb7-port1: Cannot enable. Maybe the USB cable is bad?

and freezes again.

Here is what it shows after this command.

1 Like

@Voluntario , please check this post, too:

I agree with this advice.

@Voluntario , you can install Kernel 6.3 with:

sudo add-apt-repository ppa:tuxinvader/lts-mainline

sudo apt update && sudo apt install linux-generic-6.03

You can run the above by using the Grub Menu to boot into your system or from the Recovery Prompt.

I also would recommend trying to boot Without any USB ports in use except for Keyboard And Mouse.
We can see if that makes a difference - this would indicate that USB-7 has a hardware Fault.
You may try resetting its connecting cable.

Using the advice above to set nomodeset may indicate if the PCI error is due to the GPU.

1 Like

Thanks @Aravisian and @Mr_Magoo for your suggestions.

I was able to enter the GRUB and edit the text as suggested, but I am not sure how to save it afterwards. Could you walk me through it?

Ok, I ran both commands, updated the kernel to 6.03, removed all usb devices except keyboard and mouse, and restarted the machine. Now only the original hub 8-0:1.0: config failed, hub doesn't have any ports! (err -19) error appear and the system freezes again. I guess the kernel update solved the pci 0000:0c:00.0: failed to read data problem, and removing the usb devices " solved " the usb usb7-port1: Cannot enable. Maybe the USB cable is bad?, but the main error and freezing still occur.

So I went to the next suggestion:

I was very confident that the BIOS was up to date, since I just got the motherboard, but for my surprise it has the version 1616, like 5 (!!!) versions old.
So i followed this video How to Update BIOS with EZ Flash on ASUS Motherboard | ASUS SUPPORT and tried to update the BIOS. But the BIOS updater doesn't recognize the file as a valid BIOS file. Searching about this message, I encounter this discussion, and it appears that you have to run the BIOSRenamer.exe to turn the BIOS file to a valid installation file before flashing it. Then I found this Tutorial on how to run an Windows App, but when I select Install Windows App Support, Zorin opens the software updater and just keeps loading.

Is there a terminal command to install windows app support?

Yes, but you cannot install firmware from an .exe on Windows App Support.
Windows App Support or WINE is a compatibility layer to allow some Windows applications to run on Linux. This means that it cannot be used on System Processes.

First things first, please open a terminal and run

fwupdmgr get-updates

That is the FirmWare Update Manager.

What output does it give?

When you use terminal, sudo nano /etc/default/grub, you can save and exit with
ctrl+o to Overwrite, tap enter key to save current configuration and then tap ctrl+x to exit the editor. Any time that you save a change in Grub File, you must update the Grub Process for that change to take effect. This is done by next running

sudo update-grub

1 Like

Thanks! I edited the GRUB file and updated it. Now the machine boots, without freezing or the original error message, and this is what it shows instead:

I noticed neither the WI-FI or the Bluetooth are working. In settings, Bluetooth won't turn on and the OS doesn't recognize the WI-FI adapter.

I ran this command, and this is what it shows:

It was worth trying...
It appears that you manufacturer has not submitted your firmware updates to the Linux Teams.

The nomodeset parameter may be causing this.

What Nvidia driver are you using? You can check in Software & Updates and move to the Additional Drivers tab.

1 Like

That's unfortunate... :slightly_frowning_face: So my only way to update the BIOS is having a machine with Windows, run the BIOSRENAMER.exe to turn the BIOS file to a valid one and then flashing it?

I edited the GRUB file again, and remove the nouveau.modeset=0. But WI-fi and Bluetooth is still not working. I run the system update as well, but it says it all up to date.

None. My GPU is a XFX Radeon RX 570 4 GB. In Software & Updates and Additional Drivers tab it shows No additional drivers available.

I would look to the Lower Answer on this page:

Did you remove the nomodeset parameter? Did you run sudo update-grub?

I must have been thinking of a Different thread- I was thinking you had Nvidia 3050...

You might try the radeon drivers directly:

You can double-click .deb files to run the installer.

1 Like

No, you don't need a Windows machine...

I use Win10 PE to update my UEFI, because HP only provides the files in Windows-specific format, and my UEFI doesn't have a built-in update utility.

I removed only the nouveau.modeset=0. I kept the nomodeset noplymouth. I ran sudo update-grub and the machine is booting, but still no WI-FI or Bluetooth functioning.

No problem. I really appreciate the help. Sorry, but I am a bit confused: your suggestion to update the GPU driver has something to do with the WIFI and bluetooth? Or is it because of something else?

I guess my case is slightly different. When I downloaded the Firmware update, it provided two files: an BiosRenamer.exe and the BIOS file for the utility built-in. I have to run the BIOSRenamer.exe before flashing the BIOS file to an USB stick so the Utility can run the update. I am not sure why. It is just what the ASUS site suggests:

Before running the USB BIOS Flashback tool, please rename the BIOS file (TA620MPW.CAP) using BIOSRenamer."

I had access to a Windows machine today, so I could run this BiosRenamer.exe and send the BIOS file to a USB stick. But then I realized I committed a mistake: my motherboard actually is not a 'TUF GAMING A620M-PLUS'. It is a 'TUF GAMING A620M-PLUS WIFI', and I downloaded the wrong BIOS. Luckily the BIOS utility simply said it was not a valid file. I edited my original post correcting my PC setup as well.

The nomodeset parameter can inhibit the drivers for Wifi. I think we should test if that mode setting is causing the wifi (and bluetooth) to not work.

I suggested that because above, I was under the impression that you are having issues with booting up to the User Environment without using nomodeset parameter.

1 Like

Could it mess with the sound as well? I tested the sound for the first time and there is a huge delay when I pause a video, for example, and the sound is echoing and scratching.

It was, the machine was freezing while booting and showing the error message hub 8-0:1.0: config failed, hub doesn't have any ports! (err -19)
I haven't tried booting up again withoutnomodeset.
But I tested the gpu with sudo apt-get install mesa-utils and glxgears command and it returns around 37000 frames in 5.0 seconds = 7450.655 FPS, which it seems to be the expected result.