Wifi/Bluetooth not working

Opening this Topic to adress the Wifi/Bluetooth not working commented on the original Topic related to my Zorin OS installation. hub-8-0-1-0-config-failed-hub-doesnt-have-any-ports-err-19.

Here are some info about my setup:

OS information cat /etc/os-release

NAME="Zorin OS"
PRETTY_NAME="Zorin OS 16.3"

Kernel information uname -r


(NOTE: Wifi/bluetooth does not work with kernel 5.15 as well)

Motherboard information sudo dmidecode -t 2

Base Board Information
	Manufacturer: ASUSTeK COMPUTER INC.
	Version: Rev 1.xx

BIOS version: latest version 1811

Network information lshw -c network

 *-network UNCLAIMED
       description: Network controller
       product: MEDIATEK Corp.
       vendor: MEDIATEK Corp.
       physical id: 0
       bus info: pci@0000:08:00.0
       version: 00
       width: 64 bits
       clock: 33MHz
       capabilities: pciexpress msi pm cap_list
       configuration: latency=0
       resources: iomemory:fc0-fbf memory:fc20300000-fc203fffff memory:fcb00000-fcb07fff

Settings return message No WI-FI Adapter Found as image bellow


As for Bluetooth, it won't turn on.

Everything I look at says this should be supported by the MT7921 module in the kernel.
Quick question: Did this machine used to have Windows OS installed? If so, and if Windows is not removed; it may have locked the drivers. The solution to that is to remove the CMOS battery. With the battery removed and the Power Cord Unplugged (If a notebook computer, remove the computer battery as well), hold down the Power Button for Thirty Full Count Seconds.
Set the battery or batteries back in and reboot - test.

No, brand new desktop. I bought the parts (new ones) and assembled it. Only thing second hand was the GPU.

Should I try that anyway?

You could...

This appears to be a very common issue:

Still, everything indicates the driver should be included in kernel versions after 5.12

Can you try:

sudo modprobe -r mt7921e

sudo modprobe mt7921e

I ran both commands, and the terminal did not show anything. Was it suppose to show something?

Yes, unfortunately :expressionless:

No, it isn't very verbose. If nothing goes wrong, it will not display any print.

Right. I restarted, and still no WiFi or bluetooth.
I tried disabling and enabling both WiFi and Bluetooth on BIOS, but no change as well.

I tried the rfkill list all suggested in one of the links you provided, and it showed only the bluetooth:

0: hci0: Bluetooth
Soft blocked: no
Hard blocked: no

I just tried this one too. Unplugged the power cord, took the GPU out (since the CMOS battery is behind it), took the battery out, hold power button for thirty full seconds, set the battery and GPU back, power cord back, reboot. First boot it went straight to the BIOS. Restart and it boots, but no WiFi or bluetooth functioning...

Running numerous net searches on this card, I believe it is plain that while it is supposed to have some driver support after kernel 5.12, it remains limited.

@Voluntario , much as I dislike resorting to this suggestion, you may need to consider getting a USB Wifi adapter that is compatible with Linux.

The same with apple products working with apple products.
Now when I building any PC first I watching what operating system it can be installed. No wasting time and hairs from a head. The second thing if I would buying something i checking if this pass my preferences. I better check two times to not dissapointing hardware or software if something must be working or not.

I was able to stumble upon this:

There's a link to some firmware, might or might not be useful..

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.