I am unable to select the correct time for my region (IST)

Hey all.
Each time that i power off from windows 10 and enter zorin 16 (dual boot), my time isn't synced. i have tried to change it manually each time via the GUI in settings>Date&Time but it doesn't recognise my region's time correctly. For example if it is 1 pm here, the system thinks that it is actually 11 pm. So i have to pick a time zone from a different continent or country to match my actual time.
i have tried doing the command: sudo dpkg-reconfigure tzdata and retried setting things up but didnt help.

This is a common annoyance that fortunately has a fix :wink: :


thanks! the local time trick as mentioned in the article did the job!


I sometimes use this feature to send email from the past.
"Oh, you have not got my email? I've already sent it one hour ago."

1 Like

I bounce my timezone in terminal sometimes to throw the fallout:shelter timer ahead 12 hours at a time.

This topic was automatically closed after 2 days. New replies are no longer allowed.