I can t update my driver

When i try to select my driver it shows up an error and i tried to update my driver but there are firmware missing files and when i see the name of the gpu in the about it says NVD7 and i tried to fix the problem but i ended up that i can t boot and the recommended repair in the zorin live didn't fix it so idk what to do i don t care if i will reset my pc because i didn't do alot of things i didn't even download steam because i was trying to fix the problem and when i open a game on lutris it says that it needs directx11 and something with application 3d i dont remember the exact name and something about the drivers i didn't know that it will be SO HARD TO PLAY on linux so i will wait for help i guess and the gpu is nvidia 820m.

I'll recommend you split up your problems in different threads. As it's now I don't know where to start on your problems. And please set some "full stops" as it's very hard to read.

1 Like

There aren't alot of problems there is 2 i think first it that i can t update my driver(use my gpu) and directx11 problem is because of the gpu i think. Second is haswell vulkan is incomplete i don t know how to fix it. Third is and it maybe be with the gpu is that firmware missing files. But i got a solution for the gpu(I THINK) is that i install zorin os nvidia driver safe. But i will wait for a respond from anyone to tell me if it is safe to install zorin os nvidia driver safe. my gpu is(820m)

Okay. Open the terminal and copy paste;

sudo apt install inxi
inxi -a
inxi -G

and post the output.

for the first command it says:Waiting for cache lock: Could not get lock /var/lib/dpkg/lock-frontend. It is heWaiting for cache lock: Could not get lock /var/lib/dpkg/lock-frontend. It is he

and for the second and third i don t know how to use them i just used
sudo apt install inxi and thats it

Make sure that you haven't sofware center or any updater and so on open. Close them and run the commands again.

i downloaded and thats it

inxi -a: CPU: Dual Core Intel Core i3-4005U (-MT MCP-)
speed/min/max: 798/800/1700 MHz Kernel: 5.15.0-52-generic x86_64 Up: 20m
Mem: 1540.1/3854.9 MiB (40.0%) Storage: 465.76 GiB (2.6% used) Procs: 215
Shell: bash 5.0.17 inxi: 3.0.38

inxi -g: Error 22: Unsupported option: -g
Check -h for correct parameters.

Make sure to type -G. Linux is case sensitive.

inxi -G: Graphics:
Device-1: Intel Haswell-ULT Integrated Graphics driver: i915 v: kernel
Device-2: NVIDIA GF117M [GeForce 610M/710M/810M/820M / GT
driver: nouveau v: kernel
Display: x11 server: X.Org 1.20.13 driver: nouveau
resolution: 1366x768~60Hz
OpenGL: renderer: Mesa DRI Intel HD Graphics 4400 (HSW GT2)
v: 4.5 Mesa 21.2.6

As you can see from the inxi -G command you are using nouveau driver which is the open sourve driver. The one you want to use is the restricted close source driver.

sudo apt update && sudo apt upgrade
sudo apt update && sudo ubuntu-drivers install

The first command will update your system, the other one will install the latest driver that works for your card.


the second command failed it says:Not creating home directory `/'.
Loading new nvidia-340-340.108 DKMS files...
Building for 5.15.0-52-generic
Building for architecture x86_64
Building initial module for 5.15.0-52-generic
Error! Bad return status for module build on kernel: 5.15.0-52-generic (x86_64)
Consult /var/lib/dkms/nvidia-340/340.108/build/make.log for more information.
dpkg: error processing package nvidia-340 (--configure):
installed nvidia-340 package post-installation script subprocess returned error exit status 10
Processing triggers for mime-support (3.64ubuntu1) ...
Processing triggers for gnome-menus (3.36.0-1ubuntu1) ...
Processing triggers for libc-bin (2.31-0ubuntu9.9) ...
Processing triggers for man-db (2.9.1-1) ...
Processing triggers for desktop-file-utils (0.24-1ubuntu3) ...
Processing triggers for initramfs-tools (0.136ubuntu6.7) ...
update-initramfs: Generating /boot/initrd.img-5.15.0-52-generic
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

Okay. This could be that your card isn't supported in 5.15 kernel and up as nvidia-340 is quite old (in computer standards).
Try start the app that's called something "additional driver" and give me a screenshot of available drivers.

i don t have this app

I Just booted Zorin OS up in VM :stuck_out_tongue:
It's called: Software & Updates, then click Additional driver tab.

there are 2 things

Yes? Can you post these two things or take a screenshot?

how to take a screenshot from my pc?

Hit the "Print Screen" button on your keyboard. The screenshot will be saved in your "Pictures" folder.