I cannot suspend my laptop

Hi!
I have a problem with suspending my pc.
Yesterday I applied an upgrade of ~700 mb, that upgraded the kernel, and many other things.
And now I can't suspend my laptop.
When I try to suspend, I lose internet connection, but the system is working fine, I can open applications, and do everything.
What I tried:

  • Rolling back to the 5.13 kernel, and purging the 5.15. I have the same problem.
  • Going into my windows partition and see if it suspend. It does

Wondering if it is a graphics driver issue?

1 Like

Swarf, I installed the nvidia-510 instead of the nvidia-470 and it's not working!

Wonder if using the nouveau linux driver would work?

1 Like

A lot, really a lot of people told me this...but how to do it?

Go to software updater in the menu, stop it from running then select settings. There should be an additional drivers tab. You will see a lot of nvidia drivers plus the nouveau one. Change to Noveau. You will need to do a reboot for it to take effect.

1 Like

i cannot click on them... they're greyed out

I see you manually installed the nvidia driver. You may need to uninstall that first, then the nouveau one should no longer be greyed out.

Just a quick question it says on his photo that No proprietary drivers are in use ..... wouldn't that mean he is already using Noveau driver or did I miss something ..... which I probably did .....

The driver status indicator in Gnomes Software & Updates does have a known bug that does not detect "Proprietary" when the user is using a Manually Installed Driver.

1 Like

Thank you sir I learned several new things today ..... so it has been a good day .... :+1:

1 Like

I am now on Nouveau, and I cannot suspend.
I'll keep using Nouveau, cause my system is more responsive now

This is Common Problem, with no solution. You can remove Suspend and Hibernate cause they can put your PC in a state of coma and do not work in most of the PC's. It is better to use shutdown and restart if you are facing this problem :thinking:
Cause wasting your time over this Problem is More or Less Useless :joy: