I can't activate/use wifi adapter usb

Hello,
Zorin version : core 17
64xbit
Ram: 8GB
dual boot, zorin OS on hhd (320GB) and windows 10 on ssd (120GB)
NIC : a wifi adapter usb 802.11n, name of company is GIGAMAXplus
Laptop : HP G62 but with all the upgrades mentioned beforehand
Kernel version: 6.5.0-27-generic
Got it using the command uname -r

Hello, the wifi antenna was damaged and i have a wifi adapter instead of it. It's, as i mentioned before,a 802.11n usb.

It's not working as in, when I open visible networks nothing shows up, from my experience in windows, usually i should first activate the usb /auto-run it (only the first time it's used), then in the wifi menu two drop-down menus appear;
Wifi (defaultl) & wifi4 (adapter), where the wifi4 drop-down menu shows visible networks and connects to them. But for some reason i'm unable to do this here, i'm also unable to see it in file explorer like other normal usb ( i did try multiple ports and made sure all of the ports worked fine using other devices like an optical mouth & kingstone usb)

I do know the wifi usb is working for two reasons

  1. i can still use it when I boot windows
  2. when i use command lsusb, it shows up as
    Bus 001 Device 00X*: ID 2310:1a2b SciIncX 802.11n NIC
    *: everytime I run the command/re-equip the usb, the Device number changes

I tried following a YouTube video that said to :
_ get zip file from tomaspinho/rtl8821ce from github and running the commands it said to run.

lspci | grep Network _couldn't find my NIC, only the original hardware

I also tried running software updater because i just reinstalled newly,

Any help would be much appreciated, thank you in advance

Either the wifi is so new that it aren't in kernel 6.5 or it require that you compile the driver from scratch.

sudo apt install inxi
inxi -na

Post the output of this (except the mac adresse).

Things like WiFi adaptors, Bluetooth adaptors, etc., typically don't show up in File Explorer (or linux file managers) because they aren't file storage devices.

Obligatory don't trust random drivers and binaries you find online, unless you know exactly what you're doing. That's a very quick way to either getting your machine compromised / infected, or corrupting your operating system with incompatible or broken things.

lspci shows PCI devices so it won't list USB devices, which is why you can see your adaptor in the output of lsusb.

Things to Try

  1. As you're dual-booting Windows, please check for and disable both "fast boot" and "fast startup". One is a Windows setting and the other is a BIOS / UEFI setting you may or may not have; whether your BIOS / UEFI has the option, and where to find it if so, I can't say. Unfortunately, every BIOS and UEFI is totally different, using different names for the same features even within the same brand!
  1. Run the command rfkill list all in a terminal and see if your WiFi devices are blocked at all. If so, try sudo rfkill unblock all and then run rfkill list all again to see if it changes.

  2. I have also seen some mention previously of an Acer kernel module that can block certain WiFi drivers even on machines from other brands like ASUS and HP. If you see acer_wmi or acer-wmi in the output of sudo lsmod | grep acer then it may be worth trying this fix. WMI modules are for mapping the Fn keys on laptop keyboards to system functions, such as toggling WiFi or changing screen brightness. If linux chooses the wrong WMI for your keyboard - such as acer-wmi on a Dell or HP laptop - this somehow causes the WiFi driver to fail / be blocked in the system. Why? I have no idea, it just does! :joy:

hello,
this is the output, device 3 should be my network adapter
yasmine@yasmineG62:~$ sudo apt install inxi
inxi -na
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
inxi is already the newest version (3.3.13-1-1).
The following packages were automatically installed and are no longer required:
libwpe-1.0-1 libwpebackend-fdo-1.0-1
Use 'sudo apt autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Network:
Device-1: Intel Centrino Wireless-N 1000 [Condor Peak] driver: iwlwifi
v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 bus-ID: 02:00.0
chip-ID: 8086:0084 class-ID: 0280
IF: wlo1 state: down mac:
Device-2: Realtek RTL810xE PCI Express Fast Ethernet
vendor: Hewlett-Packard driver: r8169 v: kernel pcie: gen: 1
speed: 2.5 GT/s lanes: 1 port: 2000 bus-ID: 03:00.0 chip-ID: 10ec:8136
class-ID: 0200
IF: enp3s0 state: down mac:
Device-3: SciIncX 802.11n NIC type: USB driver: usb-storage
bus-ID: 1-1.1:3 chip-ID: 2310:1a2b class-ID: 0806
IF-ID-1: enxead9afd029d3 state: unknown speed: -1 duplex: half
mac:

also something i think i should say, when i was trying on my own i found this command
yasmine@yasmineG62:~$ sudo dmesg | tail -n 20
[ 725.856291] R10: 0000000000000000 R11: 0000000000000246 R12: 0000000000000800
[ 725.856294] R13: 00007fffd9015480 R14: 0000000000000000 R15: 000056f36bdbc270
[ 725.856301]
[ 738.266968] usb 1-1.1: reset high-speed USB device number 6 using ehci-pci
[ 741.971602] usb 1-1.1: USB disconnect, device number 6
[ 787.159956] warning: `lshw' uses wireless extensions which will stop working for Wi-Fi 7 hardware; use nl80211
[ 1017.883974] usb 1-1.1: new high-speed USB device number 7 using ehci-pci
[ 1017.992783] usb 1-1.1: New USB device found, idVendor=2310, idProduct=1a2b, bcdDevice= 0.00
[ 1017.992792] usb 1-1.1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[ 1017.992796] usb 1-1.1: Product: 802.11n NIC
[ 1017.992800] usb 1-1.1: Manufacturer: SciIncX
[ 1017.993153] usb-storage 1-1.1:1.0: USB Mass Storage device detected
[ 1017.993510] scsi host5: usb-storage 1-1.1:1.0
[ 1019.021267] scsi 5:0:0:0: CD-ROM SCISC -- CDROM--AUTORUN- V1.0 PQ: 0 ANSI: 0 CCS
[ 1019.022742] sr 5:0:0:0: [sr0] scsi3-mmc drive: 62x/62x cd/rw xa/form2 cdda tray
[ 1026.136885] usb 1-1.1: reset high-speed USB device number 7 using ehci-pci
[ 1033.369642] usb 1-1.1: reset high-speed USB device number 7 using ehci-pci
[ 1063.964502] usb 1-1.1: reset high-speed USB device number 7 using ehci-pci
[ 1064.073596] sr 5:0:0:0: Attached scsi CD-ROM sr0
[ 1064.073820] sr 5:0:0:0: Attached scsi generic sg3 type 5

and when i run it again, it seems to be stuck at resetting for some reason
yasmine@yasmineG62:~$ sudo dmesg | tail -n 20
[ 2186.189423] usb 1-1.1: reset high-speed USB device number 7 using ehci-pci
[ 2218.959794] usb 1-1.1: reset high-speed USB device number 7 using ehci-pci
[ 2251.718203] usb 1-1.1: reset high-speed USB device number 7 using ehci-pci
[ 2284.492621] usb 1-1.1: reset high-speed USB device number 7 using ehci-pci
[ 2317.251055] usb 1-1.1: reset high-speed USB device number 7 using ehci-pci
[ 2340.733865] workqueue: delayed_fput hogged CPU for >10000us 4 times, consider switching to WQ_UNBOUND
[ 2350.021480] usb 1-1.1: reset high-speed USB device number 7 using ehci-pci
[ 2382.779961] usb 1-1.1: reset high-speed USB device number 7 using ehci-pci
[ 2415.546427] usb 1-1.1: reset high-speed USB device number 7 using ehci-pci
[ 2448.312895] usb 1-1.1: reset high-speed USB device number 7 using ehci-pci
[ 2481.083314] usb 1-1.1: reset high-speed USB device number 7 using ehci-pci
[ 2513.853846] usb 1-1.1: reset high-speed USB device number 7 using ehci-pci
[ 2546.612269] usb 1-1.1: reset high-speed USB device number 7 using ehci-pci
[ 2579.378768] usb 1-1.1: reset high-speed USB device number 7 using ehci-pci
[ 2612.145298] usb 1-1.1: reset high-speed USB device number 7 using ehci-pci
[ 2636.390409] perf: interrupt took too long (4931 > 4928), lowering kernel.perf_event_max_sample_rate to 40500
[ 2644.919740] usb 1-1.1: reset high-speed USB device number 7 using ehci-pci
[ 2677.682295] usb 1-1.1: reset high-speed USB device number 7 using ehci-pci
[ 2710.452791] usb 1-1.1: reset high-speed USB device number 7 using ehci-pci
[ 2743.219264] usb 1-1.1: reset high-speed USB device number 7 using ehci-pci

hello,

  1. i was able to disable fast startup from control panel but my bios version is very very old so i didn't find the fast boot option and i doubt i will
  2. i did, both give out the same output and nothing is blocked, but the problem is it didn't list the adapter but only the original hardware (probably)
    yasmine@yasmineG62:~$ rfkill list all
    0: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no
    1: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no
    yasmine@yasmineG62:~$ sudo rfkill list all
    [sudo] password for yasmine:
    0: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no
    1: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no
  3. there were some hp-wmi like you said but when i followed instructions in link, nothing really happened, no outputs were given either unfortunately

Somehow, it is being incorrectly identified as storage instead of a WiFi adaptor! Very odd!

I'm sorry, but I don't know enough about Linux drivers to try and fix that...

1 Like

Yes it appears so, probably because i used if for windows first maybe? But i have to ask, if it's viewed as a storage device, why is it not showing up in file manager ?
It's okay! Thank you for your help!

Gday @Yasmine ,
Just a few thoughts, can you remove the faulty wifi card?
If not im not sure if just disabling it in your BIOS will help, but may do, & also try the wifi switch on the side of your laptop if available.

If you can remove or disable the internal wifi, remove the usb wifi & turn off the laptop.
when the pc has shutdown, insert the usb wifi, Then restart.
give it 2-3min's & then open Software & updates & check the driver list to see if the system recommends another.

Also make sure the usb wifi is Linux compatible.
It may pay to check the manufacturers website.
Drivers also to suit.

Hope this helps.

Hello,
The Bios doesn't have such option i think, the options are
Main
- system time
- system date
- non-interactive information about pc
- Diagonisis logs
Security
_ Administrator password
_ power on pw
Diagnostics
_ primary hard disk self test
_ Memory test
System Configuration
_ Language
_ virtualization
_ Fan always on
_ Action keys
_ boot options
_ boot startup
_ floppy boot
_ cd/rom boot
_ network boot
_ boot order
Exit

Also regarding if it's compatible or not,
I'm inclined to believe it's not after trying for so long but i'm not quite sure
.There are no official websites for the company at all
.I opend a link with the same model i have and the same problem but on linux mint forum and they ended discussion at that they can't find the address anywhere (2310:1a2b)

https://forums.linuxmint.com/viewtopic.php?t=412957

But also i found this
1a2b RTL8188GU 802.11n WLAN Adapter (Driver CDROM Mode)
in this link
www.linux-usb.org/usb.ids

I tried following these commands
sudo dkms remove realtek-rtl8188eus/5.3.9~20221105 --all
sudo dkms add ./rtl8188eus
sudo dkms build realtek-rtl8188eus/5.3.9~20221105
sudo dkms install realtek-rtl8188eus/5.3.9~20221105
But didn't really work

I also tried
sudo nano /etc/usb_modeswitch.d/2310:1a2b

SciIncX 802.11n NIC

DefaultVendor=0x2310
DefaultProduct=0x1a2b
TargetVendor=0x2310
TargetProduct=0x1a2b
MessageEndpoint=0x01
MessageContent="55534243123456780000000080000606f50402527000000000000000000000"

sudo usb_modeswitch -c /etc/usb_modeswitch.d/2310:1a2b

But still, nothing was fixed ...

Did You tested the Wifi Dongle only on the same USB Port? If yes, could You test it on another Port?

No i tested it on all of the ports I have, and i tested other devices on the ports too to make sure they were working fine

Hmm ... is this a very brand-new Model from the Manufacturer? If yes, it is maybe not supported properly. That could explain why it is detected as USB Storage.

Hello, sorry for replying again this late, I couldn't find anyone else to help so I thought i could try asking here.. while searching for the name SciIncX 802.11n
I found a chinese (based on google) site that spoke about this chipset alot .
This is a google translate of an article about it there
Copyright © 1999-2020, CSDN.NET, All Rights Reserved

Open the app

Linux adds 802.11n network card driver original

2020-08-19 13:40:14

Reading
2.2k

AI Must Read

Never be a coder

8 years of coding experience

focus on

  1. Burn the image, compile the Linux kernel of the board, and overwrite the kernel file of the SD card.
  2. Compile the network card driver
    . Change the kernel path of the driver source code to the Linux kernel path, then make, and generate the .ko file.
  3. Add the function of automatically loading the network card driver at startup
    . Copy the driver file to /lib/modules/$(uname -r)/kernel/drivers, then execute depmod and restart.
  4. Reduce the startup waiting time of NetWork Manager.
    Set the waiting time to 0 in the /lib/systemd/system/NetworkManager-wait-online.service file. Save and restart.
  5. Install the DHCP service.
    sudo apt-get install isc-dhcp-server.
  6. Install the hostapd software.
    Modify the Makefile of hostapd-0.8/hostapd in the network card driver source code to arm-linux-gcc, compile make, and test the generated files and control_ap in the parent directory to the development board.
  7. Configure the software and shut down the NetworkManager service.
    Shut down the network service: sudo service NetworkManager stop.
    Start the ap service: sudo ./control_ap start wlan0 eth0

But i cannot quite follow, do you guys think this is the answer? And can someone please simplify the process :pray:,would be greatly appreciated

Again really sorry for replying back again this late