I can't get into liveboot desktop

I tried USB live boot, but after the checksum, it became stuck on the Zorin logo. I waited for approximately 30 minutes, but it continued to be stuck at the logo.
I used rufus to flash my usb into bootable.
The Zorin release that i use is Zorin Core 17 64Bit

I have attempted these:

  1. MD5 checksums,
  2. Trying to create a bootable USB on two different flash drives,
  3. Using 'dd' on Rufus,
  4. Using Ventoy,
  5. Tried with NTFS, and FAT32 file systems,
  6. Installing Linux Mint (encountering an issue - stuck on the black screen),
  7. Enabling CSM,
  8. Trying safe graphics mode (resulting in being stuck with only a black screen),
  9. Connecting my flash drive to USB hubs, front I/O, and rear I/O ports,
  10. I have tried MBR and GPT as well with Rufus and Ventoy.

Despite all of that, none of it worked.

I installed Linux Mint a month ago without any problems. Subsequently, I uninstalled it and also deleted the GRUB in the EFI partition, but today I can't install Linux Mint as well.

I tried live boot through Oracle's Virtual Box both mint and zorin, and both successfully get into the desktop.

my computer spec is
Ryzen 3 2200g
B450M DS3H V2
ram 16gb 3200mhz CL 16-18-18 (XMP Enabled)
Teamgroup T Force Cardera A440 1tb
No Discrete GPU

BIOS Settings:
Bios Version: F63
Secure boot turned off
Fastboot turned off
fTPM enabled

Thanks for any reply!
(Since I'm very new to Linux and the community as well Zorin's forum, I'm sorry if I violated the guidelines since I mentioned distro B in a community dedicated to distro A)

Zorin 16 or 17?

Oh yea, sorry for that...
I used Zorin Core 17-64 bit

This is completely unacceptable... just kidding of course it is :smiley: , you will find that a lot of us run multiple other distributions and often like to compare how they behave or look. Even Windows is acceptable since it's a tool like any other and what matters at the end of the day is to get job done. That said, if you can that job done with Linux, all the better.

I personally haven't run ZorinOS on my machines for a good while now, but I still think it's the best alternative for those who are curious about Linux or trying to get something familiar to Windows or MacOS without too much fiddling.

As for your issue, I'm not sure that deleting the EFI partitions should have an impact while booting from a USB although it certainly sounds like that may be the case. An idea that comes to mind is to boot using another distribution that allows to jump into the installer right away, instead of booting into live mode and then install. Having done that would restore the partition table so that you would be able to boot into live mode again, or at least that's the idea.
May sound biased but I was thinking of Debian for that :roll_eyes:

Sure I will try it then!
Thanks for the reply!

Are you dual booting with Windows? If so, deleting an EFI partition will render Windows unbootable. You would need to recreate that EFI partition, then install the Windows bootloader to it if that happened.

Only the grub, i reply this through windows as well, and it's been few weeks since i uninstalled Mint.
And yes i dual boot Mint with Windows before.

Is this the latest BIOS (Please confirm)?

Have you tried using nomodeset grub parameter? Or the iommu=off grub parameter?

My current bios version is not the latest version.

No i haven't.
But isn't the nomodeset is already set in Graphics Safe thing?
For the iommu, i haven't try it yet.

I recommend using your Windows boot to upgrade it.

They are both still worth trying. Yes, "Safe graphics" is often the same as using nomodeset but not entirely the same.
The Safe Graphics option instructs the system to use generic drivers and minimal graphics settings. Depending on the system, this may mean addressing modesetting.

The nomodeset parameter directly instructs the kernel to disable kernel modesetting which can allow the graphics drivers to fully load at the proper time in init, rather than having them load prior to init, causing a failure or driver conflict.

This difference can mean a difference in what the user experiences.

I see, i will try the nomodeset and iommu then

You could try to disable fTPM.

Oh yeah, thanks for your reply!

1 Like

So, i recreate the EFI partition as @Aravisian said, and its the solution that worked, so this topic is solved!
@zenzen 's might work as well perhaps about installing debian? i havent try it yet, but I guess I will try another distro someday when i'm curious and happy about it!
Thanks for everyone's reply!

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.