I cant get my HP Photosmart 7520 to print multiple copies of anything

I searched this forum & tried "sudo system-config-printer" command but the HP Printer doesnt show up, I think because I'm not connected to it via ethernet or a router?
I am connected to my printer via DIRECT wifi. No router involved. My HP Photosmart is from 2014 & is deluxe/top notch but too old to use new routers, so when I use it, I either have to disconnect from my internet & connect to it, or load everything on USB & plug USB into printer to print what I want, last method is real pain.
On Zorin or Windows the printer works well, doesnt require any software to be installed. I just have to connect to it via DIRECT wifi. But only problem is when i tell it to print f.e. 15 copies of something, it will only print the 1st one. On Windows it worked perfect & would print copies perfectly. But with Zorin in order to print 15 copies, i have to hit print button 15 times in a row. This is extremely time consuming & totally impractical. I would really appreciate it if anyone could help with a solution.
-Thank you.

Also, maybe I could download the HP software install file & install it via WINE? would that help?

Have you installed HPLIP? Your printer was supported as of HPLIP 3.12.9, currently at 3.23.3:



Having just checked after installing Synaptic Package Manager, Zorin comes with HPLIP preinstalled:

Try deleting the Printer, then Add it using AppSocket/HP JetDirect:

Enter the IP address of the Printer in the Host: box.

1 Like

@swarfendor437 , thanks! So i tried it out & it didnt work, tried all kinds of variations. 1.) First off, when i try to add a new printer, the one I have is already added, but I still tried to follow ur instructions & add a new version of it. See screenshot:

2.) I picked the IPv4 address:

3.) Entered it in, just left the default port, not sure if that matters?

4.) There were six different options/settings i could try, I tried all of them:

5.) Didnt work, i even tried without any port # at all:

I would go for the all-in-one Printer selection and in terms of the driver, use the hpcups driver. Have you checked CUPS is installed?
see if you can launch host via firefox by entering in the address bar:


1 Like

Thanks! CUPS is not showing up, my printer is not showing up under: http://localhost:631/printers/ What should i do?

Does cups not show up at all? You need to select 'Administration':

Also check out:


[Footnote: I had issues with not being able to print in GhostBSD. I got it working using CUPS to look at installing a network printer - I chose the first option that came up IPP everywhere - it now works! Something else to look at!]

1 Like

Thanks, nothing shows up under administration:

But now, my printer shows up under http://localhost:631/printers/.
Although i did not do anything to cause this. So, the problem isnt solved yet. What should i do?

Right, the second picture shows up the Driverless printer - what this means is that the Linux Kernel knows what printer you have attached but it does not have the driver. Go back to Administration and delete the printer. Next go to add printer and select 'Network Printer' - look to see what comes back - use the top option it comes back with and select that one - so long as it is not the 'driverless' model. It might also be worth installing guenprint if it is available in Synaptic Package Manager as gutenprint has all drivers for all printers included.

1 Like

Thanks so much! I owe you 100 quadrillion dollars!, I finally got it to work, I tried to delete the original printer configuration, but it actually wouldnt let me. I think its because i have to connect to it directly via wifi, I think because it considers it a constant connection & of which i cant delete, at least not that way. Regardless, i added a 2nd new version of it again, chose one version, it didnt work, so i tried yet again & chose hpcups & that worked, I can print multiple copies now :smiley: :

1 Like

Yay! You should pay yourself that money for sorting it out. All I did was make suggestions. :wink:

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.