I can't get my laptop to stop using integrated GPU instead of nvdia card

No matter what I try I can't get my laptop (Acer Nitro AN515-57) to use the RTX 3050ti GPU instead of Mesa Intel UHD Graphics (TGL GT1).

I tried going into > system tools > software updater > settings > additional drivers
I installed the recommended driver. I also went to NVDIA's website, and downloaded the Linux x64 (AMD64/EM64T) Display Driver, which took a while to install. I tried disabling safe boot in my BIOS.

Still, when I look in settings > about, it still shows the integrated GPU, and when I run a game, it displays that I'm using the integrated GPU.

I'm using Zorin OS PRO 16.2 64-bit.

Any help would be appreciated!

It appears to be only possible to do via the BIOS/CMOS settings as the alternative requires using a Windows executable which would not run under Zorin as it will be looking for Windows registry.

The only options I have in the BIOS settings under "advanced" are VTX and VTD function. Should I enable VTD?

Did you look into the prime settings in the nvidia settings ?

yes, and all it does it bring up a small dialog box that I can select "NVIDIA (Performance mode), and NVIDIA On-Demand. I chose NVIDIA (Performance Mode), and still nothing.

I got it to work following this guide:
https://www.cyberciti.biz/faq/ubuntu-linux-install-nvidia-driver-latest-proprietary-driver/

1 Like