I can't install Lazarus

Hi folks. I'm a relative Linux and Zorin noob. Actually, I've been using Zorin for a couple of years, but Zorin has been so easy to deal with that i haven't had to learn that much Linux. Anyway, I haven't been able to run Lazarus on either Z16 Pro or Z17 Pro. It seems to install, but when i try to start it, it says either ""can't find the lazarus executable /usr/lib/lazarus2.0.6/lazarus" ion Z16. On, Z17, I get the same message except it refers to "2.2.0". I thought this used to work. I've actually never used it, but I have a have a Pascal hobby project I want to work on. (Because my PC-BASIC project is nearly finished and its almost time for the port.) can someone point me in the right direction? I can't be the only one experiencing this but when I searched the Zorin forum nothing really came up. FWIW, both of these Zorin Systems are fresh installs. I ran sudo apt update;sudo apt upgrade with each install.

Hi, and welcome!

How did you install it exactly, using the command line, software store, directly from the project website, etc?

the software store.

I don't have Zorin OS at hand right now to check but I would say the package format selected for the install was either a Flatpak or a Snap.
Long story short: those are some of the several formats used by Linux for installing software. One property of these formats is that they use different path locations, which explains the error message "can't find the lazarus executable /usr/lib/lazarus2.0.6/lazarus".

So, let's try this way. Open the Software Store and search for Lazarus and uninstall it. Below the "Install" button there's a drop-down to select the source of the package. If it's available, select the one that says "Zorin OS", which corresponds to the native format used by Debian-based distributions such as Ubuntu and, of course, Zorin OS.

Alternatively, you can install through the command line:

sudo apt install lazarus
1 Like

Hey! What the heck! the sudo apt thingie worked this time, I must have been doing it wrong the first time or something. I swear to you , I had already tried that. Well, thanks for your time, I appreciate ya!

1 Like

That's a classic, everything goes back to normal when someone's watching :smiley:

1 Like