I can't set Firefox as the default Browser

It does not appear among the options in the settings, nor is there an option to set it as a default browser in firefox itself despite disabling the policy that checks if firefox is set as the default browser manually.

This is the default firefox that comes with the os


1 Like

If you have the option for "Other" you can click that, then enter the command;

flatpak run org.mozilla.firefox "%s"

Otherwise, run in terminal:

xdg-settings set default-web-browser org.mozilla.firefox.desktop

1 Like

It works! Thank you. By the way, why does firefox and some other apps have auto updates disabled by default on zorin?

1 Like

I am not sure on this, but if it was me, I would go ahead and enable them.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.