I have only one bug left

My authentication box doesn't pop up sometimes. Did a full system check including a half hour memory test. Passed.

I use Alt+F2+r to refresh desktop and it fixes it.

9 year old Dell Optiplex 3010 w 8GBs. 3 yr old BIOS.

Rarely, my desktop icons would disappear. Had that on my old Lenovo also.

Cleaning the memory and slots with alcohol seemed to help.

Tried:

sudo apt-get install --reinstall nautilus

sudo apt install --reinstall policykit-1-gnome ca-certificates

It might be that Linux/Zorin is less tolerant of old memory.

Have you tried running Memtest86+ to see if RAM is failing?

Yes. I also ran the Dell 30 memory test.

Might yank out one stick and see what happens. 4GBs is plenty.

Finally did a reinstall. Took about a half hour total. So far, so good.

2 Likes

Looks like a memory Leak. Try Consulting a Computer Hardware Expert for this Problem, only he can fix it permanetly and save a lot of your time :smile:

5 Likes

16.2 seems to have fixed it, so far. That, or installing Tiling Assistant, for some odd reason.

Still have the occasional memory glitch. Stuff disappearing or getting stuck. This on 3 old Dell and Lenovo desktops. DDR3 memory tho. Passes memory tests. Seems to be a Linux thing. I see it on distro reviews.

Found this. One click and it refreshes desktop in 3 secs.

Shell Refresh Extension.

Fixes most things.

2 Likes

Update:

The Shell Refresh extension works with Wayland. Odd because Alt+F2+R does not.