I lost connection to the network

Hello.

I have been using Zorin OS 16 Core for about 2 months now.

Today I installed and opened Proton VPN, but it had a problem while connecting to the server and terminated halfway through.
(I used the Japan server on the free plan).
When I restarted ProtonVPN, a "Troubleshooting" window appeared and I could not connect to the network.

What I tried

  1. ran "sudo service NetworkManager restart". 2.
    Tried to remove ProtonVPN by "sudo apt purge protonvpn". (Failed).
  2. restarted the computer.

Please tell me what I need to do to restore the connection.

(I used machine translation, so sorry if some parts don't make sense.)

Thank you very much for your help.
I tried and was able to remove ProtonVPN.
But I am still not able to connect to the network.
Please let me know if you know of another way.

Please open a terminal and enter:

sudo lshw -C network

and post back results.

Thank you for your reply.
I ran the command.

 $ sudo lshw -C network
 
  *-network                 
       description: Wireless interface
       product: Wireless-AC 9560 [Jefferson Peak]
       vendor: Intel Corporation
       physical id: 14.3
       bus info: pci@0000:00:14.3
       logical name: wlp0s20f3
       version: 10
       serial: 74:d8:3e:76:f5:ca
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=iwlwifi driverversion=5.15.0-41-generic firmware=46.4d093a30.0 9000-pu-b0-jf-b0- ip=192.168.1.14 latency=0 link=yes multicast=yes wireless=IEEE 802.11
       resources: irq:16 memory:a4318000-a431bfff
  *-network
       description: Ethernet interface
       product: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0.1
       bus info: pci@0000:07:00.1
       logical name: enp7s0f1
       version: 12
       serial: 80:fa:5b:7c:65:cb
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=5.15.0-41-generic firmware=rtl8411-2_0.0.1 07/08/13 latency=0 link=no multicast=yes port=twisted pair
       resources: irq:18 ioport:3000(size=256) memory:a4104000-a4104fff memory:a4100000-a4103fff
  *-network
       description: Ethernet interface
       physical id: 3
       logical name: ipv6leakintrf0
       serial: 4e:4e:de:0c:d9:79
       capabilities: ethernet physical
       configuration: broadcast=yes driver=dummy driverversion=5.15.0-41-generic


There was a bug with this card in earlier versions of Ubuntu/kernel:

Don't know if the patch in the above bugzilla thread will solve the issue or not.

Thank you very much.
I tried to apply the patch, but
I got this message.

 $ sudo patch < iwlwifi.patch 
 
can't find file to patch at input line 5
Perhaps you should have used the -p or --strip option?
The text leading up to this was:
--------------------------
|diff --git a/drivers/net/wireless/intel/iwlwifi/pcie/drv.c b/drivers/net/wireless/intel/iwlwifi/pcie/drv.c
|index 377ca8a721e7..3d511de4ca83 100644
|--- a/drivers/net/wireless/intel/iwlwifi/pcie/drv.c
|+++ b/drivers/net/wireless/intel/iwlwifi/pcie/drv.c
--------------------------
File to patch: 

Looks like an ongoing issue and apparently only one certified system that Ubuntu 18.04 works on (=Zorin 15.x):

Another user of Ubuntu claimed that turning secure boot backon solved the issue, but it did not work for another user:

You could try the intel fix here:

https://wireless.wiki.kernel.org/en/users/drivers/iwlwifi

Other information on Ubuntu 18.04