I messed up my audio with pipewire

Hi, some minutes ago I tried to install EasyEffects to enhance my audio, but since it asked me to upgrade my pipewire in order to use the app; I messed up the whole audio system after the following installation commands.

These are the commands I ran:

sudo add-apt-repository ppa:pipewire-debian/pipewire-upstream

sudo apt-get update

sudo apt install libfdk-aac2 libldacbt-{abr,enc}2 libopenaptx0

sudo apt install gstreamer1.0-pipewire libpipewire-0.3-{0,dev,modules} libspa-0.2-{bluetooth,dev,jack,modules} pipewire{,-{audio-client-libraries,pulse,bin,locales,tests}}

sudo apt-get install libpipewire-module-x11-bell

systemctl --user --now disable pulseaudio.{socket,service}

systemctl --user mask pulseaudio

sudo cp -vRa /usr/share/pipewire /etc/

systemctl --user --now enable pipewire{,-pulse}.{socket,service}

The current looking of audio, no input nor output showing up:
image

(guess I have to reinstall the zorinos now :lying_face:)

I just had to restart instead of logout -> login. there was no problem with upgrading PipeWire or using EasyEffects.

2 Likes

PipeWire working great i put somewhere topic how it works. I need every starting Zorin choose correct audio out. Don't know why don't want to be default.

yes, I have the very same problem but with the mic selection.

since my headphone is connected in front of the case and there is only one audio socket for that(audio output + mic input), It always thinks that I have the mic in the front as well but I don't. and I have to select it manually before any usage.

I like to know how to fix it if you found any solution. :heart:

I saw somewhere you can choose primary input and output audio signal in settings audio or somewhere another place. Maybe some script or some another place forum idk. This is annoying also every new update audio is changing. I saw today Zorin kernel 40