I messed up my Rhythmbox

I have to reinstall my Rhythmbox because I applied some settings that made the option buttons disappear completely so now I can't restore my usual layout with the playback controls. Clicking Remove in the Software Center brings up the dang unmet dependencies warning so I have to use the terminal.

My mind wanders back to this thread:

1 Like

Not exactly, in this case I want to reinstall Rhythmbox, I use it to play my soundtracks so I want to keep it :grin:. Do you think that I can apply the same procedure I used for VLC? So sudo apt remove rhythmbox I suppose?

I was referring directly to the:

If you are getting that warning in Software, you will get it in terminal, too.

You can try it:

sudo apt remove --purge rhythmbox

and relay what dependencies are missing.

1 Like
The following packages were installed automatically and are no longer required:
  adwaita-qt bind9-dnsutils busybox-static command-not-found friendly-recovery
  ftp gir1.2-rb-3.0 hdparm info iputils-tracepath irqbalance libaribb24-0
  libbasicusageenvironment1 libcddb2 libdvbpsi10 libebml4v5 libgck-1-0:i386
  libgcr-base-3-1:i386 libgpod-common libgpod4 libgroupsock8 libixml10
  liblirc-client0 liblivemedia77 libmad0 libmatroska6v5 libopenmpt-modplug1
  libplacebo7 libprotobuf-lite17 libproxy-tools libqt5x11extras5
  libresid-builder0c2a librhythmbox-core10 libsecret-1-0:i386 libsgutils2-2
  libsidplay2 libspatialaudio0 libssh2-1 libudisks2-0:i386 libupnp13
  libusageenvironment3 libvlc-bin libvlc5 libvlccore9 lshw ltrace
  media-player-info mtr-tiny nano python3-commandnotfound python3-gdbm
  python3-mako python3-markupsafe rhythmbox-data strace tcpdump telnet time
  vlc-bin vlc-data vlc-l10n vlc-plugin-base vlc-plugin-notify vlc-plugin-qt
  vlc-plugin-samba vlc-plugin-skins2 vlc-plugin-video-output
  vlc-plugin-video-splitter vlc-plugin-visualization zorin-os-census
Use "sudo apt autoremove" to remove them.
The following packages will be REMOVED:
  rhythmbox* rhythmbox-plugin-alternative-toolbar* rhythmbox-plugins*.
0 updated, 0 installed, 3 to be removed and 41 not updated.
After this operation, 2,488 kB of disk space will be freed.

Can I do it? I won't use sudo apt autoremove since I'll then reinstall Rhythmbox immediately and then probably the dependencies are required by other services.

You might want to just run sudo apt install --reinstall rhythmbox. This should return things to the defaults.

If not, you could always explore your ~/.config directory for rhythmbox and delete the corresponding directory. This will ensure you are using the default settings. It will be recreated when you next access the application and modify the settings.


I tried both sudo apt remove --purge rhythmbox and sudo apt install --reinstall rhythmbox but the bad configuration persists. Moreover, the Rhythmbox directory on ~/.config is missing. I think it's time to do a full cleaning, do you think I can delete all files and folders with rhythmbox on their name to be sure to clean any configuration left from uninstallations? I also know that there are certain files that Software Center saves somewhere to store software info so maybe it would be better to not remove them. But if they are recreated the next time I open Software Center again I can do it and don't mind much. As last attempt I tried different key combos, like ctrl + alt + some keys, ctrl + some keys and any other to see if I could display the toolbar but it's worthless.

I can't remember which OS but I did find an identical version of Rhythmbox but with "libre" in the name and it worked better than rhythmbox.

1 Like

Let me help you on this one!
I remove rhythmbox from every install I do of zorin os, but I reinstalled (and searched online) to see where the config files were. And, here is your solutions!

rm ~/.local/share/rhythmbox/
rm ~/.cache/rhythmbox/
rm ~/.gconf/apps/rhythmbox/ -r

If the third command fails (not found), you'll have to replace every gsetting, copying and pasting every line of these, one at a time.

gsettings reset-recursively org.gnome.rhythmbox
gsettings reset-recursively org.gnome.rhythmbox.display-page-tree
gsettings reset-recursively org.gnome.rhythmbox.library
gsettings reset-recursively org.gnome.rhythmbox.player
gsettings reset-recursively org.gnome.rhythmbox.plugins
gsettings reset-recursively org.gnome.rhythmbox.plugins.iradio
gsettings reset-recursively org.gnome.rhythmbox.plugins.lyrics
gsettings reset-recursively org.gnome.rhythmbox.plugins.magnatune
gsettings reset-recursively org.gnome.rhythmbox.plugins.replaygain
gsettings reset-recursively org.gnome.rhythmbox.plugins.visualizer
gsettings reset-recursively org.gnome.rhythmbox.podcast
gsettings reset-recursively org.gnome.rhythmbox.podcast
gsettings reset-recursively org.gnome.rhythmbox.rhythmdb
gsettings reset-recursively org.gnome.rhythmbox.sharing
gsettings reset-recursively org.gnome.rhythmbox.sources
gsettings reset-recursively org.gnome.rhythmbox.plugins.alternative_toolbar
rm ~/.local/share/rhythmbox/
rm: unable to remove '/home/luca/.local/share/rhythmbox/': It is a directory
rm ~/.cache/rhythmbox/
rm: unable to remove '/home/luca/.cache/rhythmbox/': It is a directory
rm ~/.gconf/apps/rhythmbox/ -r
rm: unable to remove '/home/luca/.gconf/apps/rhythmbox/': File or directory does not exist

Incredible how it's difficult to just restore a simple software on Linux :unamused:. I tried pasting your commands all at once and Terminal runs them separately so I didn't need to paste one by one singularly. Thanks for the reset-recursively commands, now my Rhythmbox is fine :tada::partying_face::tada:.


Yes man, sorry, I am stupid.
The first two commands were wrong. I forgot to include the -r argument.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.