I restarted the shell, and it broke (the shell?)

So I was trying to figure out whether I'm using Wayland or X11, and I found somewhere that I can do: Alt + F2 and then press r and enter. I did that (now I regret this), and there is a screen that appears saying something like:

Something went wrong, please contact support

Tried rebooting, tried doing ctrl + Alt + F2 and then doing upgrade, nothing worked.

I will appreciate if someone can help here. Need to get back to recording videos for my channel, ASAP :cry:

This should only restart gnome-shell, not break it.

To find out if you are using Wayland, you can Log Out. Then click your username at the log in screen, click the Gear Icon - check which Desktop you are logging into:

  • Zorin Desktop
  • Zorin on Wayland

Ensure you are logged into Zoin desktop. Then enter your password and log in.

1 Like

Thanks for your response, @Aravisian - But I'm not able to log in. Whenever I reboot into Zorin, there is this screen that comes up with the message I shared in the question's description. Can you help me with that please?

Log in to the Recovery Menu.
Hold the Left Shift key (Or tap it furiously) at boot up- the grub menu should offer Advanced Options for Zorin
Enter that.
Arrow key down to Enable networking. Enter and enable networking, then back out to the recovery menu. Now arrow key down to drop to prompt.
In the prompt enter:

sudo apt update && sudo apt full-upgrade


sudo apt clean && sudo apt autoremove

Once done, try booting normally.

Thanks, I did try this but doesn't work:

Ok... Can you repeat the steps above to get to Recovery Menu, then enable networking and then drop to prompt.
Enter in:

sudo apt install --reinstall zorin-os-desktop

Background (if it helps):

I was trying to build GTK4 from source: https://www.youtube.com/playlist?list=PLfjzHJeA53gSjJ92UZAHCFjpqN9z7x1Jc (not promoting at all, but just sharing what I was trying to do if that might have caused an issue).

In short, I installed glib's different version, and for other libraries as well. Can this break something?

Also, I'll try reinstalling zorin OS desktop, please give me a min.

Okay, I'm really sorry but this didn't work (reinstalling zorin-os-desktop :()...

Yes, this absolutely can break something. This is very important background. :expressionless:

Did you add any repositories to do this?

Given the amount of packages that were replaced, if you can use the Recovery Menu Prompt to make back-ups of your home directory; I Strongly Encourage You To Do So.

:frowning: I am sure I didn't do anything wrong though, one of the only reasons of me using Linux was to be able to build libraries from the source - easily. And I assume this is only with Zorin? I can be wrong.

Did you add any repositories to do this?

No, nothing! All of the libraries were built from the source.

Given the amount of packages that were replaced, if you can use the Recovery Menu Prompt to make back-ups of your home directory; I Strongly Encourage You To Do So.

Thanks, @Aravisian - so the only solution here is to re-install Zorin? :frowning:

I think it is the most likely solution. You tried to build an entirely different ToolKit (4.0) on a system built around ToolKit 3.24.
GTK 4.0 has a lot of removals for one and it also has a large number of dependencies that are different from much of what is in Zorin OS. IT would break most of the packages on your system.

1 Like

Ah! I'm really curious if this only occurs with Zorin, or other distros as well (which aren't built around GTK 4.0 Toolkit). But I get what you mean here, and it makes sense.

Sorry if this wasted your time, I should go back to distros around GTK 4.0 then, or some rolling distro release. :slight_smile:

I appreciate the help, and the info. I'll also close this now.

It can happen on any distro that is not built with the gtk 4.0 toolkit.
There are a lot of adaptations that must be done to elevate the gtk version of a system.

But if you would like to try out the Gnome 40 release, Fedora sports it, I believe. I am not sure about Arch Linux at this time.

1 Like

Right, I'm sorry if this is going out of context but can you lighten me up on this question, please?

If this was recently supported on a very few distros like Ubuntu 21.04, Pop OS 21.04 (which aren't LTS releases) and Fedora 40, how did developers manage to build it from source, use and also test apps using GTK 4 toolkit on their distros? Do you have any idea about this, please?

I'm also curious why does the official documentation not mention this as a warning. :confused:

As above, there are many adaptations that must be made by the developers.
For example, they must ensure that any apps they include are a latest version that match the dependencies of the system. The system must be adapted to the dependencies needed by gtk 4.
Some of this is done by making more extensive use of Flatpak and Snap packages. Some apps that they may normally include, are left out since the dependencies cannot be met (They are deprecated) - and so on.
That said, neither Ubuntu 21.04 nor Pop_OS come with gtk 4.
The Rolling Release Distros are using the latest (Unstable) packages and are therefore more adapted to the latest toolkit.

1 Like

This is really helpful! This might actually mean, that it's not the best time to switch to GTK 4, unless and until it's stable.

1 Like

Yes, even Ubuntu decided to avoid gtk 4 for the time being. It is very new and it uhh... It is missing a lot.

1 Like

My bad, I need to make a video on this before another person ends up following my videos to install it from source.

Meanwhile, time for me to install Zorin again :smiley: <3

Thank you @Aravisian - I appreciate the conversation and help.

1 Like

You may also look up resources on how to elevate your gtk version.
I did it on Zorin 15, elevating it from gtk 3.22 to 3.24. It was a pretty involved process and while I was careful, I still managed to break a few things. I was able to repair them because it was easier on me - I was not using Gnome Desktop (I was using Cinnamon on Zorin, instead). I was easily able to elevate Cinnamon.
That is nowhere near the jump that 3.24 is to gtk 4. I would not attempt to build gtk 4 on Zorin OS. For a variety of reasons.

It is possible to do, but it is not for the feint of heart.

1 Like

That will be a good experiment for the next weekend :slight_smile: Thanks again, I'll take a look. And also, thank you for sharing your experience, it helps a lot.

1 Like