I think I might have uninstall the display manager

Big Yikes. I know.
When I reboot into Zorin OS, I am met with tty2 like Linus did in his Steam uninstallation.

What I did.

While removing dconfig-editor, I think I removed dconf-cli and its dependencies instead.
How do I fix this?

or how do I get Timeshift to work in tty2?

I know I messed up big time. I cannot get passed the user login in tty2.
because I'm not sure the user name is.

You can try sudo apt install -y dconf-cli

It will include the dependencies, or only partially installs, you can fix it then with

sudo apt install --fix-broken dconf-cli


I reboot the PC again. This time I am not in tty2. I saw the Zorin logo but then black screen. So I am not sure if I am in the OS anymore.

How do I get into the command line to execute sudo timeshift --restore as sudo?

I tried that when I figured out I purged those. During the removal before the 1st reboot that led to this situation. I thought I fixed it before the reboot. That clearly did not work.

Alt f2 i believe will give you tty so you can use terminal

It's been some time since i used it though... maybe ctrl f2

Do I hit alt+f2 during the zorin logo?

At black screen... after zorin logo

Be right back with an update.

I'm in black screen. ALT+F2 got me to tty2.

but I am met with login user

I'm not sure what my user name is.

root did not work.

Zorin OS 16 sapphire-X570-UD tty2
sapphire-X570-UD login:

what do I do now?

Ctrl + alt + f2.... my mistake

1 Like

Or, tap the tab key or left shift or esc - aim for the Advanced Options for Zorin in the grub menu, then Recovery Menu

Arrow key to Enable Networking
Once down, back out to the recovery menu, then arrow key down to Drop to Prompt
Hit enter

sudo apt install --reinstall zorin-os-desktop


Do I do this before the Zorin logo?
I never saw the grub menu since my first installation.

Yes, start tapping keys when you see the motherboard logo. If you see the Zorin Logo, you missed it.

1 Like

So I learned that I have grub.

TAB did not work.
ESC is the key you're looking for.

Next, I am in the recovery with kernel 5.11-40. Turned on networking. Go into Prompt and ENTER.

I used sudo apt install --reinstall zorin-os-desktop. It did not work. Package could not be located.

So I did what I know for sure work.

sudo timeshift --restore. I select the latest backup. Which was Nov 30.
Thank God I did another backup.

All is fixed. Woohoo. Thanks @Aravisian @337harvey . You guys are so great. I learned another way of saving my OS.

Question: if I see the tty2,

Zorin OS 16 sapphire-X570-UD tty2
sapphire-X570-UD login:

what is my username? so that I can use sudo -i then execute stuffs from here. Instead of in recovery with root prompt.

It would be what you set up as your user login. Other than root nothing else will be recognized.

I used sapphire which is my original user and typed in the password. It kept saying wrong password. That's why I could not start executing commands. Luckily Root is in Recovery. Otherwise, I could not execute sudo timeshift --restore.

1 Like

I rather default to recovery terminal.... less hassle and takes no time to get there :grin:


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.