I uninstalled Macos KVM now Zorin 16 wont even boot

I uninstalled Macos KVM now Zorin 16 wont even boot.

Whenever I try to boot into the OS nothing happens, it just stays on the BIOS logo and I am no longer seeing the flashing Z icon over it like I normally do.

I tried to fix it using boot repair tool from a Try Zorin install that was on a USB stick but Zorin 16 still wont start.

I can still see the Zorin 16 file system when I boot from the Try Zorin USB stick and am able to copy stuff from it but would like to know if there is some way I could recover Zorin 16 and make it bootable again.

Whenever you remove a package, always check what it is taking with it. Always Read The Terminal.
I would need to install and then remove Macos KVM to see what it removes. I would rather not... So I am going to take a guess.
Boot into recovery mode by holding or tapping the left shift key at boot. Choose Advanced Options for Zorin and arrow key down to enable networking. Once networking is enabled, return up to the recovery menu and arrow key down to drop to prompt.
Hit enter.
Then put in:

sudo apt install -y gnome-shell zorin-os-desktop gdm3 plymouth

1 Like

Thanks Aravisian, I will give this a try and report back

1 Like

What I listed there are common things that may have had integrated components removed that would cause the operating system to not load or boot properly if removed.
I may have missed the mark, though... Without really knowing what was removed, it is a total shot in the dark.

2 Likes

Thats OK, I just tried doing what you asked, it did not fix it, I did however get what looked like it might be useful info..

I will post some screenshots which will hopefully be helpful in further troubleshooting the issue.

This is what I am currently seeing whenever I try to boot, just the bios screen without the glowing Z over it.

When I followed your initial instructions I got the following output from terminal

I then manually ran "sudo dpkg --configure -a" like it said and I got some more output

This is the output I got after I manually ran "sudo dpkg --configure -a"

It looks like it is saying plymouth does not exist and is skipping that theme?

I then ran dpkg from the recovery menu and got the following output

It looks like it found the plymouth-theme-spinner but I couldnt figure out what command I needed to run to apply that update.

And that is now where I am stuck at, any further suggestions would be greatly appreciated.

I forgot to add the screenshot showing exactly what update I need to install but it is not telling me what command I need to run to install it.

Unfortunately I have no idea what that command could be.

Could someone tell me what command I have to type after the following

This screen image- the top is cut off. It shows that your x-window manager is no longer required, along with a large chunk of essential apps (Whatever ryou do, do NOT run autoremove). It also shows your graphics drivers.
Really need to know what command was put in that created that message.

Is it the KVM you have installed?

Thanks again Aravisian, I gathered as much and did not run it.

I feel like I am super close to solving this, I just need help with the command I need to run after this

You can type history at the terminal to get a list of the commands. You can Also try:

sudo cat /var/log/dpkg.log

To get the output of removed packages.

sudo apt upgrade

will install any packages ready for update.

1 Like

apt list -u

sudo apt full-upgrade

It might not have been exactly the same as that but yes, it was a macOS on QEMU/KVM

When I first ran this command it wouldnt do anything, pretty sure there was no typos in what I typed as well.

After doing all of the above I left the computer for a day, came back, followed these instructions again

And now it is finally working :grinning: :partying_face:

2 Likes

I am glad to hear that your problem is now solved.

I suggest you to consider making a disk image using Rescuezilla (GUI) or Clonezilla (CUI) before venturing out into the unknown frontier next time :rocket: That way you can easily revert back to where you were before the problem.

1 Like