I updated this two packages, now I can't go back

I updated libcrypt1 and libc6 from here and here.
I need to go back to the previous versions (see what happens when I try to upgrade or install a package), so I did this for libc6:
apt --reinstall install libc6=2.28-0ubuntu1+zorin4 and it returns:

libcrypt1 : Breaks: libc6 (< 2.31) but 2.28-0ubuntu1+zorin4 is to be installed

So, I try this, apt install --reinstall libcrypt1 (apt upgrade returns the same):

The following packages have unmet dependencies:
 aptitude : Depends: aptitude-common (= 0.8.12-1ubuntu4) but it is not going to be installed
            Depends: libapt-pkg6.0 (>= 1.9.11~) but it is not installable
            Depends: libboost-iostreams1.71.0 but it is not installable
            Depends: libcwidget4 (>= 0.5.18-1) but it is not installable
            Depends: libncursesw6 (>= 6.1+20180210) but it is not installable
            Depends: libtinfo6 (>= 6.1+20180210) but it is not installable
            Depends: libxapian30 (>= 1.4.14~) but 1.4.5-1ubuntu0.1 is to be installed
 libc-bin : Depends: libc6 (< 2.29) but 2.31-0ubuntu9 is to be installed
 libc-dev-bin : Depends: libc6 (< 2.29) but 2.31-0ubuntu9 is to be installed
 libc6 : Breaks: locales (< 2.31) but 2.28-0ubuntu1+zorin4 is to be installed
         Recommends: libidn2-0 (>= 2.0.5~) but 2.0.4-1.1ubuntu0.2 is to be installed
 libc6-dev : Depends: libc6 (= 2.28-0ubuntu1+zorin4) but 2.31-0ubuntu9 is to be installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

I think the solution is to install the correct version of libcrypt1 for ZorinOS, which I can’t found.

Go to Synaptic and remove those packages. Then use Synaptic to install the correct versions.

That’s great! I didn’t knew I could do that through Synaptic. Sadly, I can’t install it using apt… I get the same output that I get when trying to upgrade. Should I install it using dpkg -i downloading it from here?
Because that would be the package for Ubuntu 20.04, no ZorinOS.

Edit: I’m chrooted into the system because I can’t boot. Will Synaptic work?

No on both. It may be quicker just to reinstall your OS. Or you can could wait for @Aravisian - he may come up with a suggestion.

Yes, at this point I could have installed ZorinOS quite a few times :sweat_smile:, but once someone told me:

Build it, break it, fix it, learn from it. Go.
So… I’m trying not to reinstall OSs…

I just found this. It seems to be a bug in that version of libc6 that breaks the system.
The guy how found a workaround (in the link above) downloaded the right package as a DEB file, thing that as far as I know, is not possible with ZorinOS.

My libc6 version is 2.28, yours is 2.31, which is not supported by Zorin, so that is likely part of your problem. And then the bug that also exists for Ubuntu users.
I agree with trying to troubleshoot as a learning experience but given that even apt isn’t working for you, I’d say you already learned from this experience and may as well reinstall. If it were something like Windows that takes half a day to install, that would be a different thing.

Yes, compatibility started this problem (well, after I touched something I shouldn’t). You’re right, I already learnt a lot from this. Thank you Carmar!

Heh heh… I like this…

First question: Can you install other packages normally? For example is you try

sudo apt install alien

Will it install as normal?

No, it returns (returned, actually) the same as when trying to upgrade.

Looks like Advanced Package Manager is the thing that is broken then. Without it, it makes it harder to install anything.
Synaptic works through APT and dpkg.

APT? Isn’t the problem in the dependencies. Besides, it is a loophole because to install the correct version of libc6, libcrypt1 has to be in an older version than the one installed and I found no way to get it.
Anyway, I already reinstalled Zorin (this time I’ll be using TimeShift :sweat_smile:).
Thanks a lot, both @Aravisian and @carmar! This forum certainly has good people and is building a strong community!

1 Like

APT is Advanced Package Tool and it is what manages installations.

Said that way, yes.