I Would Like To Enable GUI Root Login - Please Help

... and, yes, I know that this is the worst thing I could ever possibly do. I know monkeys will fly out of my laptop, set my house on fire, forge my name, steal my identity and open credit card accounts. I know it will make baby Jesus cry.
I know.
So please don't tell me what I already know.
If you can help me, I greatly - greatly - appreciate it. If not, please don't bother responding. I'm familiar with the sudo command. That's not what I want to use. I have a brand-spanking new copy of Zorin 17 Pro. I paid for it. This is what I want to do with it.
Thanks in advance.

Welcome! :smile:

Logging in as root, not too sure about a GUI --

But, you'll have to set a password first - so, sudo passwd root and then enter the password you'd like to use.

That will allow root user access, but as far as the GUI - not certain.

1 Like

THANK YOU! You da best!

No worries! :sunglasses:

Just be cautious! :wink:

1 Like

I know you already got the answer you were seeking, but I'm still struggling to understand what it was you were asking. Can you please explain, if only for the sake of mere curiosity on my part?

Thanks in advance.

I'm assuming some system config / settings / modifications. openSUSE 9 had a root GUI account you could use - much like the Admin accounts in Windows OS's. Make some changes, do some stuff, install, etc. - log out, good to go.

Could be completely wrong though lol just makes it a little easier coming from all-GUI operations. Haven't seen any root GUI's since SUSE 9 though, heh..

1 Like

Have you ever tried sudo -i and then nautilus to run the files app with elevated permissions? It would last until you closed the terminal session or the window it created. There's also a right-click context menu option which allows you to select "Open/Edit As Administrator" and will prompt you for password once and after returning from idle.

Have you ever heard of "Synaptic Package Manager"? You need only enter your admin password once to perform GUI-based installations or removals of packages without needing to use terminal. Just like a sudo session in terminal would require, this elevated access will last until you close Synaptic and you will need to just re-authenticate a new sesssion if you feel it's necessary. I love Synaptic.


You're missing the point - that was for informative purposes. I've been using Linux for over 20 years - thank you but, that's not what was being said :wink:

Some time ago, with openSUSE9, (again for informative purposes) there was a root account that could be logged in - with a GUI - make changes, install software, etc - same as what was stated before. The reason was to help users coming mainly from Windows to transition easier; instead of using terminal and a bunch of commands they may or may not be familiar with - which makes a lot of sense. But, again - just for informative purposes. Most all distros have the root account password unset. There are a lot of reasons behind this; no doubt about that.

As for what bslayers reason is :person_shrugging: - that was just speculation, and somewhat a little history on some of the older distros - openSUSE9. We'll have to wait for their response..

But, I'm sure that info might help others! :+1:


Ooof. I totally goofed and thought you were the OP. Lol... that's the only reason I provided that info. Sorry to get things confused.


No worries :laughing:

I'm positive it'll be useful to someone stumbling by though!

I'm curious to know what veteran Linux-users like you, and @bsalyers, think about the following for GUI-based approach to an Administrator account:

  1. Go to Users and Accounts. Create the "Administrator" account. Set permissions as appropriate for an Administrator.

  2. Modify the sudoers file with sudo visudo.

  3. Add username ALL=(ALL) NOPASSWD:ALL to the end. Save and exit.

  4. Log out of current non-root account.

  5. Voila - no authentication prompts for performing administrative tasks, accessing files or when using sudo.

You might notice, this doesn't take away all need to use terminal commands, but it may reduce them.

To new users:
Be wary - if you proceed with this configuration and it is successful, use it with caution. Especially if it's connected to the internet. Even more especially so if you haven't set up basic rules in Firewall (gufw). Any person (known or not) with the password to get into the newly created Administrator account can severely impair the system if they are messing around with the system files - if not altogether brick it. It would be advisable to set up a unique password for the Admin account as well, other than what you use for root access on your user account.

Interesting - that is pretty nifty!

I could see this for an admin for sure. Basic users - meh, maybe.. That may also open some security holes though! That could definitely allow access to more sensitive parts of the system and user info.

I nuke my systems trying new and adventurous things all on my own without full root :joy: could be problematic; could.. I'd kinda feel on edge having that much power all the time :smirk:


Good advice re root.


I've set a root password and confirmed it. I know it works, because I can invoke root privileges from the terminal. Yet, when I logout from my own account and try to log in as root, I get an authentication error. It's very odd, because I know the password is correct.
My ultimate goal is to be able to log in as root - from the gui - and make simple admin changes from within the graphical interface itself, rather than using sudo commands from the terminal.

Totally get that. The idea makes me nervous, as well, but I'd like to have the convenience of logging in as root, making any changes without using sudo, then logging back on with my normal user account. I'm also not too worried, as I'm running Zorin on a 2012 MacBook Pro and it contains no critical information. If it gets jacked, I'll just reinstall.

That's what I'm not too sure of with Zorin honestly; the GUI part. But, would seem like maybe that's not exactly do-able?

I honestly haven't seen a root login since SUSE9 - may be a thing of past days, now :smirk:

1 Like

Or Kali.
But Kali Linux now uses Sudo - due to the non-ending problems logging in full as Root caused.

1 Like

Forgot about Kali -- and Parrot! :person_facepalming:

Yes, I have. While not exactly what I'm looking for, invoking sudo -i does seem to come closest. Using that was how I confirmed I'm using the correct password for the root account. That's why it seems so weird that I can't log in to the gui as root.
I started fooling around with Linux about 20 years ago, after I bought a Slack CD on eBay. My idea of fun used to be setting up mixed OS networks on the weekends. :laughing:
Currently, I run a mixed Mac/Windows/Linux environment in my home.
Love SPM!

1 Like

Hey, folks. I was able to achieve my goal by following these instructions:


I can now login to the GUI as root. Turns out that in addition to setting the root password, I needed to edit a couple of configuration files (cited in the link).

Thanks to all who responded!