Ibus and Ibus Avro Installation and launch

Hi,

I just installed Zorin. Good looking and great. But I am facing installing Ibus and Ibus Avro.

In fact, Ibus and Ibus Avro are installed (found out as I tried to install those using package manager), but I can not find those anywhere installed. Cannot launch the app, cannot change the engine.
I have tried to use $ Ibus engine ibus-avro. It changes the engine, but the language remains the same.

Can Anyone help me out.

Zia.

These are applications that assist the performance of input or other applications. They do not have a GUI application manager that you can open and run.

If ibus-avro is installed, it will enable input use on your keyboard.
As you type, it should allow for phonetic translation:

There are actually GUI in other distros and you select and click to change the settings and preferences and the language of choice.
I could not find it work here.

Are you referring to this package?:

If so then:

sudo apt install ibus-avro

Then open your Zorin App Menu and type:

IBus

It should show IBus Preferences
Click that to open the GUI preferences.

And apologies for my misunderstanding.

Did all. But not working.

Terminal$Ibus --- shows the option of Ibus command. Not GUI. Even If I put $Ibus engine Ibus-avro. then the engine changes to Ibus-avro. But nothing happenes. the language does not change when I type.

Also, I can not find the Ibus GUI.

I have used Ibus GUI in Ubuntu, Kubuntu, Mint, MX. Even in Deeping. Gnome, xfce, KDE Plazma, DDE, all worked flawlessly. But Zorin is just sterile abt it. Strange.

This is strange... because I just tested this on Zorin OS 16, installed ibus-avro and opened the preferences from the app menu- as described above.

Can you please remove ibus-avro completely...(I recommend Synaptic package manager for this) and then reinstall it? Perhaps the initial install corrupted.

Sorry!!! Missed out on it. Okay going to try and let you know.

No does not work. There is no IBus app installed.

Perhaps @FrenchPress is able to assist you better than I can. I do not use additional languages.

Thank you very much Aravisian. Apprently there was no problem. Its just that there is no app installed. Rather a setting in the Settings app called "Region and Language" is there. Where is gives you the option to add more language. From there you can add Avro, or for that matter anyother language, if those are installed (usually using Sudo apt install ).

This leads me to an unsolvable problem! I am getting old.

This confuses me...
What does sudo apt install ibus-avro yield in your terminal?
On mine, it offers to install it:

sudo apt install ibus-avro
[sudo] password for :
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following additional packages will be installed:
ibus-clutter libclutter-imcontext-0.1-0 libclutter-imcontext-0.1-bin
The following NEW packages will be installed:
ibus-avro ibus-clutter libclutter-imcontext-0.1-0
libclutter-imcontext-0.1-bin
0 upgraded, 4 newly installed, 0 to remove and 0 not upgraded.
Need to get 547 kB of archives.
After this operation, 8,160 kB of additional disk space will be used.
Do you want to continue? [Y/n]