Icons added to desktop can't be moved, selected or clicked

Hello everyone,

From the start menu, or Zorin Menu how it's called in the settings, I made a couple of desktop shortcuts by right-clicking -> Add to Desktop.
Also, I have desktop icons enabled and through this placed the Trash icon on my desktop.

While I am perfectly able to move around the Trash icon in what looks like predefined slots, I am unable to either select, click or move any of the icons I made a shortcut for.

Right click -> Select All does select all added icons, but ignores the Trash icon.

As I'm brand new to Zorin, and have been using Linux only for 8 months so far, please go easy on me :upside_down_face:

I made a short clip for better understanding:

1 Like

Try changing the type of icon arrangement from the desktop context menu to force a change.

Try going into Zorin Appearance -> Desktop, and toggle desktop icons off and back on. Sometimes things need a soft restart like that to get working.


Hi @Luca_Pavan, and @zenzen,
Thank you very much for your help!

I have been able to solve this on my own by chance.
After playing a game from Steam, I've noticed that I was able to interact with the icons again.
I'm not sure if this is directly related to the game. It could have something to do with the fractional scaling I had active prior gaming, and turned off as the main screen of my 3 screens was doing funky stuff.
My the scaling was set to 125% for the main screen (2k resolution), so it would better fit to both my secondary screens (Full HD).

For testing purposes, I turned on the scaling once again, and noticed that:

  • I could not put the icons back at the exact outer edge of my screen, like in the video of my original post.
  • I was able to interact with the icons wherever I put them.

What do you guys think about it?


Nice you fixed, I didn't really think about fractional scaling giving problems to shortcuts positions on the desktop. Maybe Zorin team would like to know about this shortcuts arrangement issue if can be fixed somehow. You can now mark your message as solution :ballot_box_with_check::wink:.


Ditto, never would have thought of it :man_shrugging: