If You Suspect Your Ethernet Adapter Has Died - Read This First!

Everything is going great, you have internet, and or your network connection. Your surfing the web, streaming video, gaming online, or simply transferring files across your network. Until suddenly, without warning, your connection goes dead!

So, you do what any Reasonable person would do, you navigate to your network connection settings, and you discover this...

Thats strange? So what do you do? Naturally, you go to the cable that is obviously still plugged into your computer, and you unplug it, and re-plug it in. But that does not fix it. So you do the next natural thing, I know, have you tried turning it off and on again?

So after a full computer restart, you still notice that you have no ethernet connection. At this point, your beginning to question your hardware, is my ethernet adapter dead? In my case, this happened with a brand new computer, I seriously doubted it was the hardware.

If you were like me, and you tried to do terminal commands to start the network-manager service by typing in...

sudo service network-manager start

But all you got back were, network.manager.service not found. It leaves you down a whole new rabit trail, making you think that somehow the network-manager got corrupted or removed, and now you have to install it, but your not installing anything with no connection!

In reality, its a terrible error for terminal to throw at you. Cause in all actuality, your network-manager is still installed, its just that the service can't be started, and thats the error terminal should have given you. And the service can't be started because the OS doesn't detect a network connection at boot up.

So whats next in this troubleshooting nightmare? Well, after a nights sleep, I woke up the next morning, and I thought to myself, "Hey, I never checked the other end of the ethernet cable going into my ethernet switch, I'll check that next!"

If you have the other end of your ethernet cable plugged into the back of your router, or ethernet switch, and this is what you see...

Notice how the LED lights are not lit up? In a 100MB connection, you'll have at least 1-LED lit up. In a 1000GB connection, you will have 2-LED's lit up.

As it turned out, I had a dead ethernet port! I've heard of this happening to other's before, but its never happened to me until now. The port is literally dead, it won't serve any connection, and the LED's were not lit up.

This is what you want to see from the back of your router's wired connection, or your ethernet switch...

The moral of the story, always check the simplest things first!


Was the port really dead, or were you able to revive it by switching router off/on in true IT troubleshooting tradition?
I have only come across a dead ethernet port way back in the past, so it is not something you would initially suspect. But it is easy to find by unresponsive LEDs.
Good it was as simple as that and not some exotic software gremlin, or worse a gremlin in you new shiny machine.

In all honesty, I did not power cycle the switch, I probably should have. But since other ports are getting connection, it led me to believe that the switch is OK, just a dead port. Its Netgears cheap non administrative gigabit switch. Their not too expensive since they are residential models. But this one I am running now, replaced an even older 10/100 switch that never had a dead port.

One thing I have noticed about my router however, is that even though it supports gigabit ethernet, the speeds I get are only a little better then old 10/100. I began thinking maybe thats why 10-gigabit networks became a thing. But then thats when I realized, no, residential equipment apparently doesn't perform as commercial equipment does, and your just not going to really get the rated speed.

And the only gremlin I am dealing with, is this weird graphical glitch that I am getting. Every once in a while, the screen will momentarily flash with a horizontal or vertical line. I guess its quite common for those on Linux. I am using my Nvidia GPU driver, 460 version, so not sure why I am getting those glitches.