I'm connected to Wifi, yet I'm not?

So I've been using Zorin OS for a few weeks, and I really like it! However today, I opened my computer and it wouldn't turn on at all. I force shut it down and then started it back up, but now the wifi refuses to work. I'm connected to the wifi, but if I search up anything, it doesn't work. I'm still new to Linux so I might be a bit confused when typing in commands in the terminal. I researched everywhere but it still doesn't work. I also found a forum that said it could have something to do with a VPN? I did use ProtonVPN but when the internet stopped working, I uninstalled the VPN because I thought it was broken, (which is how i found out that my wifi didn't work after).

Hello, it could be many things but lets see if its recognised in the system;

lshw -C network
lspci

It pops up with the network. I'm reading the network details, and I see ethernet interface. I'm not connected to an ethernet though.

If you are unable to provide some system information. I can only help you with some basic causes for WiFi turning off.:smiley: :

  1. Check if Bluetooth was enabled. (WiFi and Bluetooth give a very bad experience when working together on Linux OS)

  2. Proton V.P.N has nothing to do with WiFi problems after a proper uninstall. You may check the internal V.P.N Software of Linux is turned off.

  3. People living in smart homes also have problems with poor WiFi, You may try to move closer to your access point or try upgrading your WiFi adapter and internet modem or start using Ethernet Cables.

  4. Overloading of P.C. with useless applications especially in Notebook Laptops may be the cause of your slow boot-up problem and WiFi stopping. So, remove as many useless applications as you can.

  5. If you messed up with some internet settings using online content, you might wanna undo that to previous settings. Even Removing your internet Adapter from Configuration will cause a problem.

  6. Sometimes it's not your WiFi modem or P.C. but your Internet Service Provider who mess up your WiFi.:angry:

These are the most basic WiFi problems for a Linux User and I hope this may help you Identifying your problem.:smiley:

2 Likes

I'm connected to another laptop in the same room, and my wifi is perfectly fine too. I can provide some system information, just not quite sure which system information I need to provide in order for support. Also my wifi isn't turning off, it is connected but it just isn't loading any website, or anything needing wifi.

1 Like

Press ctrl+alt +t to open terminal
and write these codes.
lshw -C network
lspci.
Provide everything it shows by pressing ctrl+shift+c and paste it here.:smiley:
Also provide the name of applications you installed recently before you faced this problem .

2 Likes

It pops up with:

description: Wireless interface
product: Wireless 7265
vendor: Intel Corporation
physical id: 0
bus info: pci@000:02:00.0
logical name: wlp2s0
version: 59
serial: 7c:b0:c2:52:a3:be
width: 64 bits
clock: 33MHz
capabilites: bus_master cap_list ethernet physical wireless
configuration: broadcast=yes driver=iwlwifi driverversion=5.11.0-38-generic firmware=29.1654887522.0 7265D-29.ucode ip=10.0.0.9 latency=0 link=yes multicast=yes wireless=IEEE 802.11
resources: irq:123 memory:91000000-91001fff
*-network
description: Ethernet interface
physical id: 1
logical name:ipv6leakintrf0
serial: a2:fd:6a:30:36:65
capabilites: ethernet physical
configuration: broadcast=yes drivery=dummy driverversion=5.11.0-38-generic

I had to type everything because my zorin os computer isn't connected to the internet.

The Adapter seem to be fine. Did you tried to connect any other device from the laptop you are sharing your WiFi with? Is the WiFi working on that device?

2 Likes

The Wifi is connected and seems to be working but the any application/website that needs wifi just won't load. I didn't try to connect any device to my laptop either.

I think what happen to u because of protonvpn app.
u can fix that by doing that instructions in the link and every thing will work very good again:

edit: i think u communicate with us from anther device, if u want to do that instructions from ur pc, u can get temporary connection to internet by editing that file: /etc/resolv.conf u will add line : nameserver ur ip of ur primary dns

Type these code and see if it works.

rfkill list all 
lsmod | grep asus
echo "options asus_nb_wmi wapf=1" | sudo tee /etc/modprobe.d/asus.conf
rfkill unblock all
2 Likes

I typed the sudo nano /etc/network/interfaces and it popped up with a screen—I'm not sure what to do next after that.

Do I save auto wlan0 into the file?

press ctrl+x to exit.

2 Likes

It says that auto isn't a command

Can connect you notebook via rj45 cable to your router? Or you can even connect your smartphone to the wifi and then connect the phone with notebook use the charging cable and enable USB tethering in the smartphone settings?
And just provide all the command results provide by @ghostminator
ValiantBoy

I'll try that, have to go in a bit so I'll update you maybe later today or tomorrow.

1 Like

You can also share the pics of the results by simple phone clicks

Also, if you were using ProtonVPN when things went south, uninstalling ProtonVPN won't necessarily solve the issue of the VPN connection no longer accessing the Wifi. It is still in the configuration file as if the VPN was still present.

1 Like

USB tethering doesn't work on my computer either.

1 Like