iMacs 2006 and 2011 wake from sleep contrast problem

I have installed Zorin 17 on two iMacs one a 2006 machine and one from 2011. Both are having the same problem. When booting and using the machines they are both fine everything seems to work correctly (networking, Bluetooth, graphics etc) although the 2006 machine is very slow; it will probably benefit from an ssd and more memory.

However here is the kicker, if I suspend either machine as soon as I wake the machine up the contrast or saturation seems to be turned right down so the screen looks almost colourless. The brightness controls on the keyboard work perfectly but this isn’t a brightness issue. The only way I can fix the issue is to re-boot.

I am sure I cannot be the only one having this problem. I have been keeping the machines updated hoping that a fix will magically happen but if there is a fix it has not been incorporated into the software updates.

Is there a fix for this problem. I am new to Linux so try to keep your answers fairly easy for a novice.

Have you tried using 'nomodeset' in your grub parameters?

  • Open a terminal and type sudo nano /etc/default/grub (changed to nano, easier editor to use I think for new users)
  • Enter your password when prompted.
  • Move the cursor with arrow keys to the line that looks like the following:

Add to the end of "quiet splash":
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset"

Example from my grub:

Screenshot from 2024-02-22 22-46-56


Once you've added nomodeset (if not already), you must run sudo update-grub before changes will take effect.

Also: when you suspend the devices, do they do the 'breathing light'?? I noticed my '09 MacBook didn't like certain kernels - some would hang on suspend, solid light.. I settled with Mint MATE, newest version and all worked except WiFi (BCM43xx install, normal 'issue') :person_shrugging: -- have you tried Zorin 16.3?

Thank you I will be in the office on Monday and I will try it. I can’t remember the breathing light but I tried Mint and I like it but I had more hardware problems, the main one being the Bluetooth mouse would not reconnect after reboot automatically and I would need a wired mouse to connect the mouse. I don’t have this problem with zorin. Also the interface on zorin is cleaner, more Mac like and the machines are being used on our trade counter so they are shared by lots of people and I think that zorin is easier.

My main issue with zorin is that when you click a programme it’s icon gives no indication that it it loading so the temptation is to click it again and then you get two instances. With Mac if you click a programme the icon bounces whilst it is loading and so you are confident that something is happening.

Yes I did try 16.3 but had the same issue.

I am having a nightmare. I typed in the command you suggested and now when the computer boots you cannot read the screen it is like the horizontal hold has gone like on an old analogue TV.

If I boot and hit escape I can get to the grub menu but I can't find a way to get to the terminal to undo the change you suggested. Now the machine is unusable is there a way to recover this machine without having to do a full re-install? Here are a couple of screen shots:-

So, nomodeset doesn't seem to be the trick - which makes me think maybe a kernel related issue..

As you're booting, if it's using BIOS to boot hold 'Shift' - if it's UEFI hold 'Esc' - once you bring the Grub menu up, go down to Advanced Startup Options, then drop to a root shell (instructions here: [HOW TO] enter Recovery Grub Menu (Advanced Options for Zorin)).

Now, you'll be asked for authentication, enter your root password - then proceed to once again enter: nano /etc/default/grub, then remove the 'nomodeset' so that only "quiet splash" is showing. Do Ctrl+O to write the changes, then Ctrl+X to exit, then sudo update-grub, reboot - and you should be back to a booting machine - but with the remaining freezing..

Once you have a bootable machine again, I'll do more investigating to try and see what's going on with freezing..

I can get to the advanced menu but I can't see how to get there to Terminal.

Selecting any of these takes you to an unreadable screen.

The second image above shows what happens if you select any recovery mode. I need to get into terminal before any screen drivers are loaded.

Select the second option that says `(recovery mode)' - that should take you to a shell.

If it doesn't, boot as normal and when you get the garbled screen, issue Ctrl+Alt+F2

You can't select that if you do you end up with this screen

Okay now issue Ctrl+Alt+F2 - that should drop you to a rescue shell, just a terminal

It doesn't I just get a garbled screen.

Can I boot in a verbose mode so that no drivers are loaded?

That should be happening with the recovery options - so I thought.

If you have the installer USB handy, you can use that to remove the 'nomodeset' parameter - just run update-grub before rebooting.

Ok So I boot onto a USB then if I run the

sudo nano /etc/default/grub

Wont that edit Grub on the USB rather than on the HDD?

Actually, nvm that's a little more involved - run the Boot-Repair utility on the Live disk:


Try the first option before doing any advanced options - that should rewrite the Grub and update, then reboot and give it a shot..

Thank you that fixed the boot problem. The original problem persists!

It is a strange problem. The screen controls work perfectly well after waking up from sleep as i say it is not a brightness problem it is a contrast problem. The whole screen looks like a white-out in a snow storm.

1 Like

No worries - but that is still a bother..

What are the specs to that machine - CPU, RAM size, GPU? I was doing some searching on the '06 model - saw 1GB of RAM and a Core 2 Duo.. Have you considered using Zorin Lite 16/17? That might be partly causing the issues - if there's not enough resources to keep up, that is.. You could try increasing the swapfile size and trying a suspend to see if that helps, performance wise.

I believe 2GB is the size set from installation - you can up that to 4GB with:

sudo -i (enter password)
swapoff /swapfile
rm /swapfile
touch /swapfile
chmod 600 /swapfile
fallocate -l 4G /swapfile (<- 4G = 4GB)
mkswap /swapfile
swapon /swapfile

The white screen - I'm looking into that one as well.. if you do have an Nvidia card - what driver is being used? You can open Software & Updates and then the Additional Drivers tab:

Depending on your GPU, you may need to use an earlier version of driver - like the 470, or maybe even the Nouveau driver. My '09 MB had to use that one - couldn't use any of the proprietary drivers..

(edit / update)
Saw some others with older Mac's having similar issues - turned out to be driver related. I'm willing to bet an earlier driver version would be best suited; probably for both.

1 Like