Impossible to access internet | No Wi-Fi Adapter Found

Hi, I hope I’m asking the question at the right place.
It can seem like i didn’t do any researches (because multiple topics with “No Wi-Fi Adapter Found” do exist), but nothing that I read/tried did solve my problem.

A few hours ago I installed Zorin successfully to my computer, but I cannot access wifi, and my laptop (Asus ROG G14) does not have an ethernet socket. Also, I do not have any adaptators.

I was asking to myself if Zorin 15.3 does support a WiFi as new as a WiFi 6 from a really recent PC ?

Anyway, since I do not have any way to connect the computer to internet, I’m asking here if this is possible to put some drivers/packages on a USB key to install/update the computer with Zorin
If yes I do not know how to install manually a package and which ones I would need.

  • as far as I know, it seems impossible to do sudo apt update whithout any internet connexion. Same for every installation
    -> ie : I tried with linux-generic-hwe-5.4.0-56-g
  • I tried to install lsb-core from a flash drive, but i’m redirected to the Software & Updates app, and when I click install I see a progress bar for less than 1 second. Then no installation is made / no error message.
  • so it’s impossible for me to do any update/installation to the computer and I do not have a deep enough knowledge of Linux to install stuff manually

Thanks for your time, reading and help !

Could you please run

inxi -n

in terminal and paste the output here?

Sorry for the waiting time, I thought i would have an auto-email !

Well even inxi is not installed
I don’t see the inxi download for Zorin OS on https://pkgs.org/download/inxi
Which one should I take ?

I put this in an usb key and then I type sudo apt-get install ~/[MyUsbKey]/[nameOfInxiFile] ?

You can use

sudo apt install inxi

Though, that is odd… Inxi comes pre-installed on Zorin.

I also use pkgs.org- Vigorously. I keep it bookmarked. Zorin 15 is based off of Ubuntu 18.04, so when looking for a package on pkgs.org, scroll down to Ubuntu 18.04 for the one you want.

I will admit— that your system could not find inxi and that your wifi is not working out of the box makes me concerned that your installation is missing files. If it is a brand new installation and has had no wifi- I would encourage you to reinstall Zorin OS.
Make sure you attempt to connect to wifi while in the Ubiquity Installer and also check the box that says -download updates while installing. Check on Normal installation.

I used pkgs.org by chance but now you said it I will preciously save it ! (since you know better than me all this stuff haha)

Well I tried to re-install Zorin and it did the same. But I kept the same USB key. Maybe I should also redo from zero the USB key’s configuration

I remember both times I made the installation I did check the box, but there was no wifi step. Also there was no wifi logo in the top bar. Just one for the battery and an other one (maybe to power off the computer)

For the inxi package installation, I had this :

Reading package lists... Done
Building dependency tree
Reading state information... Done
Package inxi is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'inxi' has no installation candidate

I did first tried when the package were on flash drive, then I tried when the package was on desktop

Do you agree that I have to first configure the usb key ? (or I can simply let the zorin iso file ?) Maybe I followed a “bad” tutorial ? Which steps/video/link should I follow to configure the USB and install Zorin correctly (if you still think I should re-install it) ?

Package inxi is stable in the repository and is not referred to by another package. That is strange.
Can you go to the App Menu (Start menu) and click “Software & Updates”
Then, on the first tab that is open when it gives the Popup Window, check that “Download from” is set to “MAIN SERVER.”
This is just to check why it is not seeing Inxi.

To Reinstall:
Download Zorin from the download page:

Here is the Zorin Main site Guide:

To check your MD5sum:
Zorin Core 64bit: 6b31a1fd73a756aa1a40555ec13a6f6e
Zorin Lite 64bit: 9438e56c7480c298bd326f9a4322dea3
Zorin Education 64bit: da0918c9f2a6e2f26127e9ed9c42638f

The download is set to “Server for France”

Wow I didn’t know things like MD5sum did exist
I’ll try all this and keep you updated, thanks !

Ok, you need that set to Main Server. Once installed, be sure to go into Software & Updates, and change that first.
Check if you have Net connection. IF you do, then:
While in that application, go to the last tab for Jockey, “Called Additional Drivers” check if there are any that you need. Then, open a terminal and enter

sudo apt update

Then,

sudo apt dist-upgrade

If you do NOT have net connection, we will try more troubleshooting.

So I did again the installation with the links you sent to me!

  • after downloading Zorin OS, I checked my MD5sum (with QuickHash), it does match
  • at the first boot of the installation of zorin, when we see lines of code scrolling, I saw “initframs unpacking failed” error. I don’t now why it did this. This was just the first line. After this everything happened as expected.
  • then during the steps I saw the wifi step (I never was this happy to see a wifi connexion request)
  • then I had to do the manual installation since I need to keep my Windows aside
    1. I did delete all occurencies of my previous Zorin installations (10Gb backup, 4Gb swap, ~100Gb space)
    2. I did redo these spaces to install zorin
      -> all these “redo” steps are from this Youtube Video
  • I saw a LOT of error / problem doing [stuff] during the installation logs

Well It does not work

Installation Failed
The installer encountered an error copying files to the hard disk:

[Errno 5] Input/output error: '/rofs/usr/share/icons/ZorinRed-Dark'

This is often de to a faulty CD/DVD disk or drive. It may help to clean the CD/DVD, to burn the CD/DVD at a lower speed, or to clean the CD/DVD drive lens
(cleaning kits are often available from electronics suppliers).

Right after

We're sorry; the installer crashed. After you close this window, we'll allow you to file a bug report using the integrated bug reporting tool. This will gather information about your system and your installation process. The details will be sent to our bug tracker and a developer will attend to the problem as soon as possible

The popup did never close

What I will do is

  1. re-format properly this part of my hard drive from windows (and not manually)
  2. configure a most recent flash drive (this one is 10 years old now)
  3. be able to click the “Install Zorin alongside Windows” button

=> to be sure it’s not my fault and we can try something else

EDIT : my flashdrive seems to be broken, I cannot format it or anything else

1 Like

lol

Looking over your post, I think User fault is least likely.
I think what got you was this:

I know how to fix that- but first you must be able to boot the system.
Let me try playing around with a Zorin ISO and see if anything can be done while you are retracing your steps.
Are you installing zorin Core or Zorin Lite or Zorin Ultimate or Zorin Ultimate Lite?

Edit:

…or this may be it…

Thanks ! I’m using Zorin Core

Ok, I am downloading a copy to check a couple things out. But… Given that you posted a suspicion of your USD and given Multiple issues in one go, (Initramfs unpacking failed on a NORMAL system is usually pretty harmless), from wifi to other failures— I suspect you need to try a different installation medium. Might try DVD disk (preferred) if you have the means available.
USB installations are Notorious.
But if USB installation method is your only option, trying a differnt (or new) USB stick is a good idea.
If you have the same trouble with installing from a New USB, then we can try a few other things, here.

After a few days being really busy I tried it again !

First try

What I did:

  • format the Zorin disk part from Windows10
  • chose “Install with NVIDIA drivers” option
  • select language and basic stuff
  • “install Zorin OS alongside Windows Boot Manager”
  • features are installing (I see the loading bar)
    There is no step about wifi
  • installation complete, you need to restart

=> Once everything was finished No Wi-Fi Adapter Found in the settings…

Second try

  • “Try or install Zorin OS” (didn’t select nvidia option)
  • chose language
  • chose keyboard language
  • then it did bring me to the Install step so I did hit “back” then “Quit” then forced my computer to turn off… yeah I don’t know

Finally

  • Re-re-re-re…try AGAIN
    -> “Try or install Zorin OS” (didn’t select nvidia option)
  • chose language
  • chose keyboard language WHITHOUT double clicking (why? I dunno) my keyboard choice on the right (just a simple click, then I did hit “continue” button)
  • magically I saw the wifi step (woow!!) so I registered my wifi
  • at the “Updates and other software” step, I checked the boxes (Download Updates while installing Zorin OS, Instal third party software for graphics, wifi…, configure secure boot)
  • click Install Zorin OS alongside Windows Boot Manager
  • chose location, name, password
  • it installs everything -> loading bar -> then “Installation complete, restart now”
    It seems to work ?!!!
    -> Zorin OS functionnal
    -> Wifi ok

So I typed a little inxi -n aand not found…
BUT ZORIN WORKS THAT’S AMAZING
I can’t believe it

Thanks for your help and your instant readiness
I’m so happy

1 Like

By the way, I did forget to chose Main server in Software & Updates, I am doing it right now

Do I have to check all checkboxes ? (including “Source code”, because it is not checked)

No, you can leave Source Code on each entry unchecked.

Congrats on your success.

Thanks so much !!