In HDMI audio 7.1 the rear speakers are silent

I've searched for a solution on internet but no success so far in finding one.

In Sound panel (also in PulseAudio) everything seem fine i.e. I can select "HDMI 7.1", but when performing a speaker test for the rear right speaker, I'm hearing from the side right speaker "Rear right".
Anybody having a solution for this issue or can point me in a direction?
Thanks in advance!

Any possible solutions here?:

Hi [swarfendor437],

Thanks for your quick response :slight_smile:

Unfortunately, after performing the indicated steps in the provided link/post, nothing changed.

Just to be clearer, when laptop is in 7.1 and 5.1 configuration, the 5 speakers are working fine, but still ignoring the 2 rear speakers. I'm sure that the receiver can use the rear speakers because I was able to perform a calibration of those from the internal setup program of the receiver.

Probably more details could help to identify the context of my issue and then perhaps a solution:

My laptop HP Envy TouchSmart 17 (m7-j078ca) is connected to an A/V Pioneer receiver (VSX-1027-K) using an HDMI cable. When the laptop is active, I see on the A/V receiver's display "PCM" with a graphical layout of the wired speakers which exactly corresponds to my 7.1 configuration.

Furthermore, in the Zorin parameters for "Sound", I'm able to select the right output configuration i.e. HDMI 7.1.

Because of the above, I've concluded that on a hardware aspect, everything is fine and normal.

My issue is when I'm doing speaker tests, for example by clicking the "Rear right" icon I'm hearing the voice "Rear right" from the side right speaker. Samething as when I click the "Side right" icon (which is OK in this case).

It looks like even if the system is recognizing all the hardware, the system is ignoring the rear speakers no matter what.

I hope the details provided will give a better understanding of the problem. However don't hesitate to ask any question or give any comment.

Thanks again!

I appreciate where you are coming from. I think audio is getting worse generally in GNU/Linux. I for one detest Pulse Audio. I have a SoundBlaster Audigy 5Rx connected to Logitech speaker system, sub-woofer, left and right front, front middle, and two rear speakers and even in ALSA sound does not come out of the correct speakers in test mode. I suspect the test speaker element is outdated. Play some music and try to put your ear to each speaker to see if sound is coming out of each. (Front right for me ends up as muffled sub-woofer!) I think I have only had sound working perfectly once using Devuan 3 with Plasma.

Open alsamixer in terminal.
Check if any speakers or even headphone channels are muted [MM] or volume set low.
Select channel affected and hit "M" key to unmute, up arrow to increase volume.

EDIT: As you are using HDMI output you may not see speaker channels on alsamixer :frowning:

Sound issues on linux are a on-going puzzle and frustration to many of us.

Hi swarfendor437,

I've tried to play some music, unfortunately no sound was coming out of the rear speakers.

I appreciate your help. Time for me to give up... for now at least.

Thank you very much for your concern.
Have a beautiful day!

Hi zabadabadoo (or should I call you Fred?),

As you expected, HDMI in Alsamixer one cannot see individual speaker. Nevertheless, I was able to confirm that all channels were not muted. Sadly, still no sound from the rear speakers.

Anyway, for now I'm putting this issue on the side. Nobody knows if at some point someone will find the culprit :thinking:

Thanks and have a nice day!

1 Like

What sound card is in that HP Envy of yours?

Hi all helping people!

Following the post from 337harvey, trying to change the encoding, I was playing around with some features of my A/V receiver using my remote control, then I suddenly heard the rear speakers!

I'm a little bit shameful to say that the problem was more on my ignorance of my A/V system. There is a feature for "Switching the speaker terminals". This option caused the sound for the rear speakers to be redirected.

However, I greatly appreciated your help because your involvement indirectly pushed me in the right direction and it was not useless for me given the end result!

Godspeed to all!


Wow a sound issue solved!
Frame that post.


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.