In Wayland, Japanese input method don't work correctly

In Zorin 17 and Wayland, Mozc Japanese input method don't work correctly. When I switched to X, it became normal. Wasn't it too early to enable Wayland by default?

2 Likes

Did you try to adjust the Japanese Input in the Gnome Settings? Ther You have a Keyboard Menu where You can add a Japanese Keyboard Layout. You have there the following Options:

There is no problem with the keyboard layout. In X, the color of the phrase being converted is inverted, but Wayland is not.

Oh, okay. I understood that wrong. I thought You have Problems to get a Japanese Layout. Maybe Wayland doesn't support that Mark. I like Anime but I don't speak Japanese. Is this Marking an essential Thing? If yes, I think You should use X11.

1 Like