Incorrect Terminal Command?- Microsoft Font article


I decided to look closer into this.
When I click the Copy prompt on the command on that page, I get

​<200b>sudo apt update && sudo apt install ttf-mscorefonts-installer

Pasted into my terminal.
But if I paste it in notepad or here on the board, the


does not appear.

This is repeatable for me and happens each and every time.
It also occurs whether I use ctrl+shift+v or Right Click > Paste.

I bet that is the cause of the issue. I have never had any trouble linking sudo commands with && before so, I figured something else had to be at play, here.


Thanks for looking into that, and thanks again for all of your help with getting set up. I am thrilled to be using Zorin OS without issue.

I still have a few things to set up, and may still need to run windows on dual boot, but I think Zorin will be my main OS. It's beautiful and feels great.

Thanks again

1 Like

Thanks for letting us know about this issue, it looks like there was indeed an invalid hidden character in this command.

We've now corrected this command on our Help article about Microsoft fonts.

1 Like

I thought it was really strange when sudo wasn't present, but then something worked later on... however, this is some really clever insight, well done.

Yet another case of how blindly copy + paste commands from the internet is a bad idea!

1 Like

We solved the mystery!

driving scooby doo GIF

Thanks again!

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.