Inkscape thumbnails invisible

@Storm , you are pretty good with Inkscape...
I have run into a problem that I never had before.

Installed Inkscape with apt (as I always do).
When using the following script:

for a in $(find `pwd` -type f -name '*.png'); do inkscape -z -f "$a" -l "${a%.png}.svg"; done

It prompts me on each and every file. Which when converting a few hundred images, cannot happen.
If I set in preferences to Not Ask...

All the file Thumbnails are blank.

If it is set to ask, the thumbnails are not blank.
The file contents are fine... But I cannot see the image thumbnails in the folder and that, too, cannot happen.

I tried searching this but... No... No, the internet is quite silent on this.

I needed to set from link to embed, then uncheck the box for "ask" - and now thumbnails render properly.

You should probably get the latest inkscape. There's an official PPA for it :slight_smile:

I Just came home for 10 min. ago.

Only way to do that would be with flatpak.:expressionless:

sudo add-apt-repository
sudo apt update
sudo apt install inkscape


Tried it out... It broke everything.
I have rolled back to the previous version.

A bunch of my Batching Scripts now just say "function deprecated."

This is depressing.

Sorry to hear that. I don't had that kind of trouble with it.

What does that script do if I may ask? I roughly looks like it converts from one format to another? :thinking:

Batch convert .png to .svg - Or you can reverse it and batch convert text-based .svg to Raster .png.

It's one of many different ones I use for batch handling images... since... you know... Icon sets... it's a lot.

1 Like

I'll try it out, I suppose this works best with rather simple images right? svgs for relatively complex images can be challenging I would imagine

No, that script or the reverse can be used on any images.

for a in $(find `pwd` -type f -name '*.png'); do inkscape -z -f "$a" -l "${a%.png}.svg"; done
for a in $(find `pwd` -type f -name '*.svg'); do inkscape -z -f "$a" -l "${a%.svg}.png"; done

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.