Install fails on a Very Old Dell Inspiron570

Hi-

Just got a 2010 Dell Inspiron 570 Desktop, and can't get an install of any Linux system on it. I suspect the bios is way out of date.

It runs Windows 7 just fine, but every install stick I use hangs after choosing the OS on the initial grub screen.

Machine has 8G or Ram, AMD processor (fairly good one for its day). Radeon 550X video card, no wifi, ethernet.

I've tried Zorin, Mint, POP, all the same issue.

Any hopes for it? Or is is gonna be WIn7 till it dies?

Have you checked in BIOS Settings if set to AHCI or RAID?
In Win7, is the original (First generation) of Windows Fast Boot disabled?
Are you installing as Legacy?

1 Like

You can consult a Hardware Expert, Sometimes minute hardware missing can reject an entire operating system install. In windows example, the Trusted Platform Module (TPM) version 2.0 is needed to install Win 11. As you mentioned it has no WiFi and Ethernet then think what else might be missing. It is not always the Software

If it is a Sempron processor that could be the issue:

Your machine when on sale had a choice of 3 processors, the lowly Sempron (AMD's equivalent to Intel's Celeron), Athlon or Phenom.

http://uk.dell.com/uk/en/corp/Desktops/inspiron-570/pd.aspx?refid=inspiron-570&s=corp

Did you attempt to run as "Try Zorin" from the live USB?
Did that work?

Hi-
AHCI is enabled, my other option is ATA
Secure Virtual Machine is disabled
Nothing enabled on the bios security tab
Fast boot not available in the bios, Win7 has no setting for this feature (think it came along in Win8 or 10.

Thanks

Not sure this is related to the question, but have you tried running a memory test?

Yes, passed.

I got his machine from someone who, from the amount of dust inside, had never opened it. I cleaned it out, re pasted the CPU, put in a video card, and booted it up into Windows 7. They previous owner had done a clean install. It's running fine, on the network.

I think it's probably going to stay windows 7. I just use it to play music in my woodshop, and that it does!

Have you tried to update the BIOS yet?

I looked into it, but can't find a bios update anywhere.
I don't really need to install Linux on this box, but it's the first computer I've run across that won't take an install. I haven't tried any Linux distro outside of the Ubuntu based derivatives I had mentioned, may give that a go. I have one software program that runs on Windows 7, so If I try again, it will be a dual boot. I'll put in a second drive. The software I want to run (besides the music player) isn't real happy in WINE, or for that matter on various VM's I've tried. It's a real oddball situation.

Thanks, It's the Phenom

Have you tried burning .iso to DVD?

1 Like

Excellent suggestion. I cannot believe I forgot this...

This was given in the old ubuntu post I posted above. If it didn't boot at all from USB it might not be enabled in the BIOS, and PLOP can solve that issue.

https://www.plop.at/en/bootmanagers.html

I used it to install Wolvix Cub many years ago on a Toshiba Satellite 4030 brick that only had 84 Mb RAM!

1 Like

Interesting, thanks. May give it a try if my "boot from DVD" fails.

If this is an old rig, be sure to use an Optical Device cleaner like this one:

Well, after using a Ventoy USB and choosing Linux MInt 21 and leaving it overnight, I came downstairs in the morning to find the live demo up and running. I played with it for a while, and decided to do the install. It installed just fine, and I've run the usual updates and things seem stable.

Go figure!

1 Like