Install GOG titles on Zorin

If you would like to start a Thread on that, I wonder if @Michel and other GOG users could help.

3 Likes

@budutz, what game from gog are you trying to install. Most games i install from gog do work perfectly in lutris.

1 Like

I created a new thread for Zorin gamers.

2 Likes

I have been trying to play one of my games in GOG. Installation works fine but playing return this message often.

You have been transferred to the existing GOG thread with a help of Moderator's Magic Wand (TM) :star2:

2 Likes

Dragon Age origins Ultimate (will start the launcher but then return directx error)
Syndicate Wars (DOS games not working at all. something with the wine prefix error)

I tried the first step with Repair-boot.
At first it won't install so i thought maybe Zorin can't add the ppa

So i tried terminal method, and i couldn't make it work either. Now I retried the first step using copy paste from browser to terminal (before was simply typing from my phone screen to terminal). It started the download, update, and checking and repairing..i hope.

Will come back if this solve after reboot.

You need to configure lutris, i can help you with that. Also some games do require directx, normally with gog it gets installed.

I got Cyberpunk 2077 to work and Mass Effect Legendary Edition under lutris. When the Starship Troopers Terran Command demo got launched i got it to work at launch with steam proton.

I moved some discussions to this thread which is dedicated to the GOG subject.
:star2:

2 Likes

Download the game setup files. I am not using gog galaxy client, trying to avoid that.

Ok, I'll try to check later this night and see if offline installer will work better. If it is, i hope my DOS games also work.

I recommend to you minigalaxy, available in Software and works fine for me. Please let me know if it works for you too.

1 Like

Or if you prefer a non-Flatpak:
link to .deb file.

2 Likes

Ok I tried downloading the offline installer last night. Failed 2 times. The first one direct from browser download. Always failed in the 2nd part of the file. Then I tried Lutris and download from there, both also failed to download one of the parts. I am not sure if this is my ISP problem or GOG server problems but most likely my ISP since it has been giving me up to 1,2mbps averaging 380kbps speed lately.

I then tried to install NW2 complete offline installer that i have backup a year ago and tried to install it but it gave me warning instead about installing from unsecured sources. So i stopped.

I will try either the minigalaxy @cefre00 suggested or @Aravisian later tonight.

2 Likes

Tried downloading minigalaxy and this message pop up. basically the same thing when I was using Mint. However following the guide will most likely make the system broken since I know my old NVIDIA card will not work with the latest NVIDIA driver.
PoP OS was one that taught me the hard way. Installing using the NVIDIA version will result in over size screen and unable to see much but a portion of screen. However installing Intel/AMD version of PoPOS will work normal for my screen.
After changing few distros before Zorin, I don't want to break my system again or reinstall/timeshift again.

Now you see why I linked to a .deb file, avoiding Flatpak.

1 Like

It's not only flatpack but his nvidia driver as well. That older driver does not support the new features.

2 Likes

Good point. that is a pretty old card. I guess in the end, everyone must upgrade eventually.

2 Likes