Install MS TrueType fonts for PlayOnLinux

Installed Wine and POL last night, then installed the MS Spyder board game. The game window opens but is blank. Oh pooh! I figured out the debug feature and found the POL log and it states I need to install the MS TrueType fonts. Search here and found no clear solution to doing that but, I did use POL to install MScorefonts...which did not resolve my problem.

I tried attachng the POL log but do not see a way to do this.

This is what I found doing a simple google search, perhaps this can help you

Well...hmm. I am having issues with the /winprefix/yourprefix/ part of this.

Using the "ls ~/.PlayOnLinux/wineprefix" command the response is MicrosoftSpider.

Below is what I entered:

$ cp usr/share/fonts/truetype/msttcorefonts/* ~/.PlayOnLinux/MicrosoftSpider/your prefix/drive_c/windows/Fonts

$ cp usr/share/fonts/truetype/msttcorefonts/* ~/.PlayOnLinux/wineprefix/MicrosoftSpider/drive_c/windows/Fonts

I don't use wine or playonlinux... so I really couldn't tell you.

Have you searched the forums on Play on Linux? That is your best place to look over the OS forum.

I found this one as well doing a google search: https://www.playonlinux.com/en/app-346-Microsoft_Fonts.html

You can install the fonts directly on Zorin OS:

sudo apt install ttf-mscorefonts-installer

Thanks but...I tried that last night and no joy. The POL debug log states this:

[10/11/22 15:37:43] - Running wine-1.7.25 spider.exe (Working directory : /home/lou/.PlayOnLinux/wineprefix/MicrosoftSpider/drive_c)
Wine cannot find the FreeType font library. To enable Wine to
use TrueType fonts please install a version of FreeType greater than
or equal to 2.0.5.
http://www.freetype.org
fixme:htmlhelp:HtmlHelpW HH case HH_INITIALIZE not handled.
fixme:htmlhelp:HtmlHelpW HH_PRETRANSLATEMESSAGE unimplemented

I will guess the issue I have with the solution offered by DeanG is I am using the incorrect syntax. Freetype.org shows a solution but it involves compiling and I do not think I am up to that just yet...especially not knowing if their solution will work on Zorin.

Installing a few MS games are all that holds me back from disconnecting my Win 7 and sticking it in the basement. :slight_smile: