Install stuck on "Creating ext4 file system for / in partition #1 of SCSI1 (0,0,0) (sda)"

I have an old laptop (Dell Inspiron N5010) that I can't install Zorin on, it is always stuck on "Creating ext4 file system for / in partition #1 of SCSI1 (0,0,0) (sda)". I have tried everything I know but it still doesn't work

What I have tried:

  1. Opening Zorin Live Mode then setting all disk as unallocated space in GParted, then creating a new partition with filesystem ext4.

I saw the logs and it repeats the following messages a lot:
"Source ID "number" not found when attempting to remove it"
"XDG_RUNTIME_DIR (/run/user/999) is not owned by us (uid 0), but by uid 999! (This could e.g. happen if you try to connect to a non-root PulseAudio as a root user, over the native protocol. Don't do that.)"

Please help.

I suspect, although I'm not sure, that this has to do with how your drive is set up to be accessed in the BIOS. Check to see if you've got AHCI enabled. Press F2 during boot to access the BIOS. Under Advanced, you should see SATA Operation with the options of ATA, AHCI and Intel Smart Response Technology. Select AHCI, then try the install again.

It's already AHCI, weird...

Try doing a drive test... I'm not sure if the N5010 has built-in tests in the BIOS, you might have to download a LiveCD image that has a drive testing application... it may be that your drive's got some bad sectors.

I have a live image of zorin, maybe this will help?
I'll try doing a test now.

I'm running ZFS, so I don't use badblocks, I use zpool scrub, but it should be something like:
sudo badblocks -vws /dev/sda

Note that the -w option destroys data (it does write testing)... which in your case shouldn't matter, because you're attempting a fresh install. If you've got data you want to save on that drive, remove it before running the above.

You can issue:
man badblocks
... to get the commands for it.

You can also issue:
sudo e2fsck -cfpv /dev/sda
... which uses badblocks, and attempts to repair (remap) bad sectors.

Or, if your drive is SMART-capable, you can force the drive to remap bad sectors by writing zeros to every sector... as soon as the drive firmware recognizes a bit write error, it'll enter that block into the badblocks table and replace it with one of its spare sectors (if it's got any left):
sudo dd if=/dev/zero of=/dev/sda bs=512 status=progress
Note that doing so completely zeroes every sector on the drive... all data is lost.

If you run Zorib in live mode, run Disks which has a drive test tool built in. I'd attach an image but am responding via phone.

turns out my hdd is faulty :pensive:, I ran a dell diagnosis test in the boot menu and all was fine except the hdd, it gave error code 2000-0142.
I was actually working on a persistent USB for Zorin using MKUsb, but I don't know it will work or not.

It might not be the drive itself.

A PSA/ePSA diagnostic code of 2000-0142 indicates the the HDD (hard disk drive) Self Test was unsuccessful. It could be the HDD, HDD cable, or connector on the motherboard. Open the system, remove the HDD, clean the connectors (on the motherboard and on the drive), reseat the HDD. Run the PSA/ePSA test again. It could just be a dirty connector.

Removing the hdd in an inspiron is PAIN, It requires opening the whole system and removing the keyboard. I'll just create a persistent usb and run from it, OR i'll maybe buy a new drive, the laptop is from 2010!

Maybe your Inspiron N5010 is different. My N7110 is really easy to get to the drive... there's a panel on the underside of the laptop, remove it, remove one screw, the drive slides back a bit then lifts out.

I think that's the same for yours:

See that big panel right in front of the battery compartment? I think that's the access to your drive.

that's the access for ram, not the hdd.
I saw green sticks inside, not an hdd.

The video here shows it, Dell Inspiron n5010 Hard Drive Removal - YouTube
its a bit tricky....

I've only ever had to take the N7110 completely apart to replace the fan... twice. Yeah, it was a bit of a pain, but the second time around went much more smoothly, since I knew where the little plastic 'hooks' were that kept the case together, so I could pop it apart much more easily.

Is there a way to run Zorin entirely from usb WITH PERSISTENCE, because I think there is a bug about casper-rw.
That's the only way if the hard disk is bad
I don't want to open it

It should work... just plug in an external USB drive, set up your BIOS to boot from that USB drive, install Zorin OS to that USB drive.

Did a test, the drive has over 20,000 bad blocks. I even cannot get a new drive.
I remember it fell before, so that means that the head crashed into the disk and damaged it.

I do not think USB with persistence works on Z16 using usual tools like unetbootin, rufus etc. I believe it is a problem originating from Ubuntu. Z15 being OK.
I have heard that persistence may work ok if you use Ventoy to create Z16 USB boot drive. I have never tried it myself though.

30 thousand, ugh.

If you are patient and careful I would replace the drive with a SATA M.2 SSD of 1 Tb.